All users were logged out of Bugzilla on October 13th, 2018

Keyboard navigation cold be better

VERIFIED WORKSFORME

Status

()

--
minor
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: vda, Assigned: joki)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
open 2 Mozilla windows (for example, I opened URLs
http://bugzilla.mozilla.org/query.cgi and
http://www.mozilla.org/projects/nspr/reference/html/prlayer.html)
Switch to 1st wnd. Switch back to 2nd one.
Up/down keys do not scroll the text. They do nothing.
I think they should scroll.
(Reporter)

Comment 1

18 years ago
Created attachment 40263 [details]
Example showing info window with long URL

Comment 2

18 years ago
I'm confused. How does that attachment relate to the Keyboard Navigation?

If I open two window and I give focus to each one then I can switch as many
times as I want and not lose the ability to scroll with the arrow keys.  Are you
seeing something different?
Assignee: asa → joki
Component: Browser-General → Event Handling
QA Contact: doronr → madhur
(Reporter)

Comment 3

18 years ago
>Are you seeing something different?

Yes, I do see something different! When I switch to another Mozilla
window, I can't scroll with arrow keys until i click inside that window.
I see this on NT 4.0.

In general, I think Mozilla have a couple of UI 'buglets' of this type.
They are almost not worthy reporting individually but annoying.

Comment 4

18 years ago
Vlasenko, do you still see this bug in 0.9.2 or in nightlies?  I think what you 
saw was bug 84501, "Focus memory broken on win32".
Denis, do you still see this problem with current nightlys?  This worksforme on
Win98...
WFM 2001082909 on Win2k. Reporter: If you disagree, please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
Works for me too

Comment 8

17 years ago
verified wfm on buildID: 2001-09--4-00trunk win2k
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.