When i use "Save as" on an attachment and change the extensionless base file name I can't open it from Windows Explorer

RESOLVED DUPLICATE of bug 414865

Status

RESOLVED DUPLICATE of bug 414865
5 years ago
5 years ago

People

(Reporter: giuliana, Unassigned)

Tracking

17 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 758633 [details]
example of attachment with other name

User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E; BRI/2; POS2)

Steps to reproduce:

Opened an e-mail with an attachment, clicked on save as, selected the file where I wanted to save the attachment and changed the name of the attachment (so i can know later what it is).


Actual results:

It saves the attachment but I can't opened it. When I try to open it appears a message: "Choose a program to open this file" And it gives me a list of a lot of programs: Word, PDF,  Corel DRAw, Photoshop etc.......
But I can't open the file even if I choose one of these programs above. I just can open the attachment normally if i don't change the attachment's name.


Expected results:

It should save and open normally.
giuliana, thank you for your bug report and sorry for the inconvenience. Indeed, this is a known bug in TB (bug 414865). Unfortunately we haven't yet found a volunteer to fix it - if you are or know a coder, most welcome.

As a workaround, you can do this:

Say your attachment is called "oldname.zip"
So when you save as, it will show only base file name without extenstion: "oldname" (because Windows hides known extensions by default, you could also change that for a more permanent workaround).
When you rename during save as, remember to add the correct extension manually:
Save as > "newname.zip"
This will preserve the correct extension, and you can open it as expected on your system.

Alternatively, re-add the correct extension by selecting affected file in windows explorer, press F2 to rename, then add extension (should work if there's really no extension; won't work if there's another hidden extension). Personally, I changed my windows settings to always show all file extensions including known extensions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414865
Summary: when i save an attachment and change the name i can't opened it → When i use "Save as" on an attachment and change the extensionless base file name I can't open it from Windows Explorer
You need to log in before you can comment on or make changes to this bug.