[leo-pre-iot-br] manual network selection not performed

RESOLVED WORKSFORME

Status

Firefox OS
Gaia
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: dpalomino, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [leo-pre-iot-br])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 758661 [details]
manual nw selection not performed - logcat

Device: leo
buildid: 20130529095707 (brazilian variant)

Manual network selection is not performed. 

Steps: 

1. Settings > Cellular & Data > Network Operator
2. Enable "Automatic selection": nothing happens. No new carriers are listed, no frequency scan is done, and the help message (i.e. "Turn automatic selection off to view available network operators") still appears. 

This has been also tested with leo and build 20130524, with both Vivo and Tef-Spain SIM cards, and behavior is ok. 

Attaching logcat about this. I don't think it'd be a radio issue, it seems more like a gaia interface not working (not asking for the manual selection process). 

Nominating for leo?
(Reporter)

Comment 1

5 years ago
Created attachment 758663 [details]
radio logs for the issue

Comment 2

5 years ago
The newer version (FW ver.: V08a) was released.
This issue was fixed in V08a.

Please, check it and make a feedback.
If it is not reproduced, I will change the status.
Flags: needinfo?(dpv)
(Reporter)

Comment 3

5 years ago
Restested with v08: 

build 06/07:
Gecko revision : 08e8a7bbebec924c24a5187a3c0b2ef1ef6d08da
Gaia revision : e2346ca0297f40547e64a7eebc4bd2e4a4cdaf86
QC commercial RIL : AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.115

And behavior with this version is ok, manual network selection is performed. 

resolved/fixed
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(dpv)
Resolution: --- → FIXED
==> Works for me because there isn't a patch associated with this to indicate what fixed this bug.
blocking-b2g: leo? → ---
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.