[B2G] Unable to find any wireless networks

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: nkot, Assigned: mwu)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, firefox24 unaffected, b2g18 verified, b2g-v1.1hd fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 758724 [details]
logcat

Description:
Device cannot find any wireless network, shows none is available during FTU and from Settings app

Repro Steps:
1) Manually flash Leo to Build ID: 20130605070207
2) Proceed with FTU process
3) Observe available networks lis on "Select a network" page
4) Complete FTU
5) Open Settings
6) Select WiFi option
7) Toggle on the Wi-Fi switch 

Actual:
 "Available networks" section displays Searching status, while during FTU "Select network" screen shows notification "We could not find any wireless network"
 
Expected:
 List of available networks is presented to a user during FTU and from Setting app

Environmental  Variables:
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/09dc1ae3b1b5
Gaia: 92a6e36957145cdb2ac8867e5cdba8ecf12308fc


Notes:
Repro frequency: 100%
See attached logcat for more info
Reproducible on both Mozilla RIL and COM_RIL
Also seen on the Buri commercial and mozilla RILs.

Build ID: 20130610070206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8e3f39363c54
Gaia: ce3b99781d182ad550a325206990c249b0dbcf0e
Version: 18.0
Summary: [B2G][leo] Unable to find any wireless networks → [B2G] Unable to find any wireless networks

Comment 2

5 years ago
going to leo+ this as im sure no one else will argue this is a blocker.
blocking-b2g: --- → leo+
Keywords: regression, smoketest

Comment 3

5 years ago
mwu thinks bug 868913 regressed this.  he's investigating now.
Blocks: 868913
(Assignee)

Comment 4

5 years ago
Bug 868913 backed out on b2g18.

https://hg.mozilla.org/releases/mozilla-b2g18/rev/a80a19cf1170
Assignee: nobody → mwu
status-b2g18: --- → fixed
status-b2g-v1.1hd: --- → affected
(Assignee)

Comment 5

5 years ago
I haven't seen any evidence of wifi bustage on mozilla-central, so resolving fixed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-firefox24: --- → unaffected

Updated

5 years ago
Duplicate of this bug: 883245

Comment 8

5 years ago
Fixed on leo on the following build with Commercial RIL:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/c3a5f0dbb9c6
Gaia   ba4c3763514dbb9fd1dd886b4b6f3bff50bad264
BuildID 20130614115117
Version 18.0
Status: RESOLVED → VERIFIED
status-b2g-v1.1hd: fixed → affected

Updated

5 years ago
Flags: in-moztrap?

Updated

5 years ago
Flags: in-moztrap? → in-moztrap+

Comment 9

5 years ago
This issue is still reproducing on the Buri (see comment 1) 

Build ID: 20130617070209

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/f1b84d841ced
Gaia: 9dd0acc74c8e04218749917c85367a8080fa3cb1
Platform Version: 18.0
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Please file a followup for the bug you are indicating here. This is already a landed patch.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
status-b2g-v1.1hd: affected → fixed

Comment 11

5 years ago
New bug opened, please see bug 883919
Verified on Leo 1.1 mozilla RIL.  User can now see and select Wi-Fi networks.

Build ID: 20130624070224
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/62049a1c5d36
Gaia: 885b874029d8143035765ae903c147a9415fcc52
Platform Version: 18.1
Status: RESOLVED → VERIFIED

Updated

5 years ago
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.