Status

()

--
critical
RESOLVED WONTFIX
6 years ago
3 months ago

People

(Reporter: jgilbert, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

Trunk
All
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

It's more a graphics bug than a profiler one.

Do you have STR?
Version: unspecified → Trunk
It's caused by the profiler failing to unwind when we're running in a graphics driver in linux that dosn't have proper frame pointers. Breakpad unwinding will fix this.
(Reporter)

Comment 3

6 years ago
STR appears to be trying to use the profiler with gl-layers enabled.

Loosely speaking, the profiler is walking its way all the way into the driver, at which point it gets lost and falls down.

This appears to be fixed with `profiler.unwinder`=true, and according to BenWa:
  Alternatively if you just want pseudostack then you can turn it back off and
  turn off profiler.stackwalk and youll get simple profiles reliably.

Updated

6 years ago
Crash Signature: [@ libgcc_s.so.1@0xeb30] → [@ libgcc_s.so.1@0xeb30] [@ libgcc_s.so.1@0xefa8]
Blocks: 1329181
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.