Closed Bug 87998 Opened 19 years ago Closed 9 years ago

Autocomplete search option icon doesn't always show (forgets search prefs)

Categories

(SeaMonkey :: Location Bar, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 663919
Future

People

(Reporter: roaminglt, Unassigned)

References

Details

(Keywords: polish)

Attachments

(2 files)

When typing a URL into the location bar an option to search for the inputed
string is given.
This search option has a logo associated with it.
Upon loding my browser with search mode as basic this logo did not appear.
Switching to advance made it appear. Switching back to basic would not make it
dissapear again.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1+) Gecko/20010626

Attaching screenshots.
After closing and re-launching Mozilla I cannot reproduce this. However it did
occur.... can anyone else reproduce at all?

Pushing severity down to trivial.
Severity: normal → trivial
reassign to hewitt, author of this and owner of icon issues
Assignee: alecf → hewitt
I see this all the time - strangely, every time I change my search engine in
prefs, then restart a few times, the pref reverts back to Netscape search, and
the image disappears from the drop-down.  I think Matt fixed this recently,
though.  If you see this bug with recent builds, try setting your search engine
again in prefs or starting a new profile, and hopefully this bug won't appear
anymore.
Status: NEW → ASSIGNED
Above screenshot was taken with build 2001062803. This error therefore stil
shows in the latest available build at time of writing this.

This is hardly a serious bug.. in fact it's nigh on irrelevant as it makes no
difference to function. Never the less.. it's there and could do with fixing
when there aren't any bugs more serious than this... ha.... that'll be the day :)
I have determined that this only happens when you install new nightlies.
Priority: -- → P4
Target Milestone: --- → Future
*** Bug 102548 has been marked as a duplicate of this bug. ***
*** Bug 108184 has been marked as a duplicate of this bug. ***
> ------- Additional Comments From Joe Hewitt 2001-06-27 13:49 -------
> I see this all the time - strangely, every time I change my search engine in
> prefs, then restart a few times, the pref reverts back to Netscape search, and
> the image disappears from the drop-down.  I think Matt fixed this recently,
> though. 

Yes, I see the exact same behavior. The icon disapears, but it still actually
searchs google. In prefs though, Netscape is selected. Setting back to google
will bring the icon back, but as soon as I restart, icon is gone, and Netscape
is selected again. See also 87699. (full path to search engine stored in prefs).

Upping severity since the prefs show up wrong as well (I suspect hitting OK in
that panel WOULD actually set it to Netscape).
Severity: trivial → normal
Keywords: polish
Sometimes the text in the search autocomplete does not even show
Too weird, i never had this in older builds
Using Build 2001111603 on Windows 2000.

After I installed this build, I created a new profile.  Using this profile,
Mozilla starts in Classic theme by default and with Netscape Search as the
search engine to use.  The icon shows, no matter what search engine I switch to.

Then I switched to Modern theme.  Since "Bugzilla @ mozilla.org" was the last
engine I set while in Classic theme, this was used for searching.  But, the icon
did not show up.

Then I switched the search engine to dmoz.  The icon for dmoz shows up when
typing text in the adress bar.  After that, I switched back to "Bugzilla @
mozilla.org", and the icon for bugzilla shows.

I switched back to Classic theme, and "Bugzilla @ mozilla.org" was used for
searching.  No icon shows.  Changed to Google, icon shows.

Then I restarted Mozilla.  Icon for Google does NOT show.
*** Bug 121950 has been marked as a duplicate of this bug. ***
using 2002022703-

Happens every day.  I have yet to get through an entire day or even a few hours
where the search icon consistantly remains.

I've noticed that a crash is a definite way to loose the icon, but it also
happens whenever it feels like it as well.  Isn't there SOME way to make it stay
all the time, as it also affects the right click "search xxx for.." feature too.
*** Bug 131654 has been marked as a duplicate of this bug. ***
This bug is probably for all platforms, not just Windows 98; see bug# 131654 for
the Linux O.S. which has been marked as a duplicate of 87998. Also, it might be
a good idea to change the summary since it no longer describes the complete bug
with additional comments.
Thanks, Phil
OS->All
OS: Windows 98 → All
Summary: Autocomplete search option icon doesn't always show → Autocomplete search option icon doesn't always show (forgets search prefs)
Just a by the way..

seeing this on: 2002061604/linux
Confirming on LinuX Mozilla 2002062307
I'm getting annoyed by this bug and I want to fix this. Assigning this to myself.

I have investigated this a bit and found out that the icon URL from RDF source
is null (in file urlbarBindings.xml). I don't know why, though.
Assignee: hewitt → Kalle.Valo
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
*** Bug 244782 has been marked as a duplicate of this bug. ***
Setting Hardware=All per comment 21. Any luck with this, Kalle? Still planning
to work on it? If not, please reassign back to default component owner.
Hardware: PC → All
Just upgraded from 1.7rc2 to 1.7rc3 and it definately happenned again, caused by
the upgrade.  (I think it also happenned when I went from 1.7rc1 to 1.7rc2 but I
wasn't looking for it then so I'm not completely sure of the causation).
Let's face it, I'm not going to fix this after two years :) Reassigning back to
the component owner.
Assignee: Kalle.Valo → location-bar
Status: ASSIGNED → NEW
QA Contact: claudius
This is probably related to bug 300561.  Does anyone have consistent steps to reproduce that don't involve changing the program directory?
with changes to the location bar over time - is this bug now irrelevant/resolved?
Product: Core → SeaMonkey
Fixed in Bug 663919.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 663919
You need to log in before you can comment on or make changes to this bug.