Closed Bug 880010 Opened 6 years ago Closed 6 years ago

Intermittent browser_webconsole_bug_597103_deactivateHUDForContext_unfocused_window.js | uncaught exception - NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener] | Test timed out

Categories

(DevTools :: Console, defect)

defect
Not set

Tracking

(firefox24 fixed, firefox25 fixed)

RESOLVED FIXED
Firefox 25
Tracking Status
firefox24 --- fixed
firefox25 --- fixed

People

(Reporter: RyanVM, Assigned: msucan)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

Attached image osx screenshot
https://tbpl.mozilla.org/php/getParsedLog.php?id=23820165&tree=Fx-Team

Rev5 MacOSX Mountain Lion 10.8 fx-team opt test mochitest-browser-chrome on 2013-06-05 10:32:06 PDT for push 0f23a2e50620
slave: talos-mtnlion-r5-055

10:50:36     INFO -  TEST-START | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_597103_deactivateHUDForContext_unfocused_window.js
10:50:36     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_597103_deactivateHUDForContext_unfocused_window.js | Console message: OpenGL LayerManager Initialized Succesfully.
10:50:36     INFO -  Version: 2.1 APPLE-8.0.51
10:50:36     INFO -  Vendor: Intel Inc.
10:50:36     INFO -  Renderer: Intel HD Graphics 3000 OpenGL Engine
10:50:36     INFO -  FBO Texture Target: TEXTURE_2D
10:50:36     INFO -  1370454636495	Sync.Status	DEBUG	Status.login: error.login.reason.no_username => error.login.reason.no_username
10:50:36     INFO -  1370454636495	Sync.Status	DEBUG	Status.service: service.client_not_configured => service.client_not_configured
10:50:38     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_597103_deactivateHUDForContext_unfocused_window.js | there were no errors
10:50:38  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_597103_deactivateHUDForContext_unfocused_window.js | uncaught exception - NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener] at chrome://browser/content/tabbrowser.xml:1715
10:50:38     INFO -  Stack trace:
10:50:38     INFO -      JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 1136
10:50:38     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
10:50:38     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_597103_deactivateHUDForContext_unfocused_window.js | Console message: [JavaScript Error: "NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener]" {file: "chrome://browser/content/tabbrowser.xml" line: 1715}]
10:51:06  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_597103_deactivateHUDForContext_unfocused_window.js | Test timed out
10:51:06     INFO -  args: ['/usr/sbin/screencapture', '-C', '-x', '-t', 'png', '/var/folders/zp/62c7k2vn5x79yp_l57twm0mh00000w/T/mozilla-test-fail_6ES0uP']
10:51:06     INFO -  libpng warning: zero length keyword
10:51:06     INFO -  libpng warning: Empty language field in iTXt chunk
10:51:08     INFO -  SCREENSHOT: <see attached>
10:51:08     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_597103_deactivateHUDForContext_unfocused_window.js | finished in 30033ms
10:51:08     INFO -  TEST-INFO | checking window state
10:51:08  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_597103_deactivateHUDForContext_unfocused_window.js | Found a browser window after previous test timed out
https://tbpl.mozilla.org/php/getParsedLog.php?id=23828148&tree=Mozilla-Central
https://tbpl.mozilla.org/php/getParsedLog.php?id=23818597&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=23824333&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=23827444&tree=Mozilla-Inbound


Looks like Windows tacks on another failure for good measure.
10:07:42 WARNING - TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/modules/test/browser_taskbar_preview.js | Got the expected number of windows - Got 1, expected 2
Any idea what has suddenly caused this test to misbehave? :-)
Flags: needinfo?(past)
Maybe Mihai can think of something.
Flags: needinfo?(past) → needinfo?(mihai.sucan)
This is a variation of bug 874635. The fix I did there seems to be insufficient. There's some other kind of breakage in the windows tab previews code and I do not have sufficient experience with it.

Rob, can you please look into this bug and bug 874635? Thank you!
Flags: needinfo?(mihai.sucan) → needinfo?(tellrob)
See Also: → 874635
I didn't even think that these ran on OSX seeing as they're Windows-specific tests! I was pretty sure that I wrote code to self-disable the test on anything but Windows 7 but it's been years. Either way, I'm not involved enough with the project to have time to look into this anytime soon. Cowardly punting to Jim.
Flags: needinfo?(tellrob)
Jim, can you please check these intermittent failures? See comment 16 and 19, and bug 874635. Thank you!
Flags: needinfo?(jmathies)
Flags: needinfo?(jmathies)
I really don't know this code at all as I don't work on firefox front end / dev tools. Maybe there is someone from that group that can poke at this? FWIW, I can't reproduce locally.
(In reply to Jim Mathies [:jimm] from comment #87)
> I really don't know this code at all as I don't work on firefox front end /
> dev tools. Maybe there is someone from that group that can poke at this?
> FWIW, I can't reproduce locally.

I'm not sure what your timezone is, can we sync to talk on IRC?

I know the web console code, but the exception happens in the windows-specific taskbar preview code - please look at the tbpl logs of the test failures. The test only opens some windows and closes the quickly...

There seems to be some kind of a race causing an exception. I tried to identify it and fix it in bug 874635 and it seems that work wasn't sufficient. I would appreciate it if I could talk with someone who knows that code. Any suggestions? Are there some events I should wait for, other than window load?

Thanks!
(In reply to Mihai Sucan [:msucan] from comment #88)
> (In reply to Jim Mathies [:jimm] from comment #87)
> > I really don't know this code at all as I don't work on firefox front end /
> > dev tools. Maybe there is someone from that group that can poke at this?
> > FWIW, I can't reproduce locally.
> 
> I'm not sure what your timezone is, can we sync to talk on IRC?

sure, next week some time. I'm always on #developers and #windev.

> I know the web console code, but the exception happens in the
> windows-specific taskbar preview code - please look at the tbpl logs of the
> test failures. The test only opens some windows and closes the quickly...

There are multiple failures in dev tools, which leave a window open that later shows up in a taskbar test as a unidentified window. The taskbar failure is just a side effect of whatever went wrong in browser_webconsole_bug_597103_deactivateHUDForContext_unfocused_window.js.
Tried to make the test to wait as much as possible before attempting to close windows and tabs.

r=me

Landed in inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/381473907cd0
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/381473907cd0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.