Status

()

Core
Editor
P2
major
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: JongAm Park, Assigned: Kathleen Brade)

Tracking

({regression})

Trunk
mozilla0.9.3
x86
Windows 98
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [html])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows 98; Win 9x 4.90)
BuildID:    20010607

The Composer can't handle well with "", '', and <>.
For example,the Composer of the Mozilla has some problem with codes looks like :
   .... document.write('<H1>blah blah </H1> "this" "that" '>

Some of my HTML files saved with the Composer looks like :
   ... document.write("lt;H1>blah blah .....


Reproducible: Sometimes
Steps to Reproduce:
1. Write HTML files which have JavaScript functions whose parameter
looks like '<....> "<....>" ....' 
2. Open it and save it using the Composer.
3. investigate the code.

Actual Results:    ... document.write("lt;H1>blah blah .....


Expected Results:     .... document.write('<H1>blah blah </H1> "this" "that" '>

I use the RapidControl for Web product.
It has some special strings called RapidMark.
Maybe the problem is related the RapidMark.
(Assignee)

Comment 1

17 years ago
could you try with a newer version of mozilla?
I think this is a duplicate of a bug I may have already fixed.
If you can still reproduce this bug with a newer version, could you please attach 
a more complete example?  For example, I can't tell if your document.write stuff 
is in an attribute or in a <script> section or ?
Assignee: kmcclusk → beppe
Component: Compositor → Editor
QA Contact: petersen → sujay

Comment 2

17 years ago
brade
Assignee: beppe → brade
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: correctness, nsBranch, regression
Priority: -- → P2
Whiteboard: [html]
Target Milestone: --- → mozilla0.9.3

Updated

17 years ago
Keywords: nsBranch

Comment 3

17 years ago
just did some testing on this one, I will attach my test case.

1. open test case in browser, select File|Edit
2. in composer, enter some text, save it out under a new name
3. open saved test case in a simple text editor, content is fine

marking as wfm, reporter if your test is different than the one I have attached,
please attach a test case and reopen if you can repro this one.

Comment 4

17 years ago
Created attachment 40702 [details]
js test case

Comment 5

17 years ago
wfm
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

16 years ago
Verified in 8-30 build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.