All users were logged out of Bugzilla on October 13th, 2018

Assertion failure: !cx->isExceptionPending(), at vm/Interpreter.cpp:3162 with OOM

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86
Linux
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jsbugmon:bisectfix])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
The following testcase asserts on mozilla-central revision 204de5b7e0a6 (run with --ion-eager):


function SameValue(expected, actual, description) {}
function currentFunc()
function BigO(data) {}
function compareSource(expect, actual, summary) {}
function optionsInit() {}
var lfcode = new Array();
lfcode.push("gcparam('maxBytes', gcparam('gcBytes') + 4*1024);");
lfcode.push("\
function testLenientAndStrict(\
code, lenient_pred, strict_pred\
) {}\
function raisesException(exception) {\
      eval(code);\
};\
function parsesSuccessfully(code) {};\
function parseRaisesException(exception) {};\
function clean_uneval(val) {}\
function deepEqual(a, b) {}\
");
lfcode.push("\
base =\
(function(){\
eval('throw new Error()')\
})();\
");
while (true) {
  var file = lfcode.shift(); if (file == undefined) { break; }
  loadFile(file)
}
function loadFile(lfVarx) {
    try {
      lfRunTypeId = parseInt(lfVarx);
      eval("(function() { " + lfVarx + " })();"); 
    } catch (lfVare) {    }
}
(Reporter)

Comment 1

5 years ago
Created attachment 759065 [details]
[crash-signature] Machine-readable crash signature
(Reporter)

Comment 2

5 years ago
Jason, is this likely the same problem as bug 877437?
Flags: needinfo?(jorendorff)
Summary: Assertion failure: !cx->isExceptionPending(), at vm/Interpreter.cpp:3162 → Assertion failure: !cx->isExceptionPending(), at vm/Interpreter.cpp:3162 with OOM
Whiteboard: [jsbugmon:update]
(Reporter)

Updated

5 years ago
Whiteboard: [jsbugmon:update] → [jsbugmon:update,ignore]
(Reporter)

Comment 3

5 years ago
JSBugMon: The testcase found in this bug no longer reproduces (tried revision b7175c5829b5).
(Reporter)

Updated

5 years ago
Whiteboard: [jsbugmon:update,ignore] → [jsbugmon:bisectfix]
Blocks: 865960
Flags: needinfo?(jorendorff)
I can't reproduce this in rev 204de5b7e0a6, debug build, with --ion-eager.

Does it still reproduce for you? Is it linux-only?
(Reporter)

Comment 5

5 years ago
Not sure if this particular one is still present, I get lots of these assertions but possibly with different causes. I'll close this one as WFM and file new ones.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.