build on uClibc: error: 'cairo_null_surface_create' was not declared in this scope

RESOLVED DUPLICATE of bug 722975

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 722975
5 years ago
4 years ago

People

(Reporter: Natanael Copa, Unassigned)

Tracking

20 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20130417 Firefox/20.0 (Nightly/Aurora)
Build ID: 20130417094959

Steps to reproduce:

tried to build firefox on Alpine Linux, which uses uClibc instead of glibc.


Actual results:

ccache g++ -o gfxReusableSurfaceWrapper.o -c -I../../dist/stl_wrappers -I../../dist/system_wrappers -include /home/ncopa/aports/main/xulrunner/src/mozilla-release/config/gcc_hidden.h -DMOZ_ENABLE_FREETYPE -DGRAPHITE2_STATIC -DIMPL_THEBES -DHB_DONT_DEFINE_STDINT -DMOZ_OTS_REPORT_ERRORS -DMOZ_GLUE_IN_PROGRAM -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES -DSTATIC_EXPORTABLE_JS_API -DNO_NSPR_10_SUPPORT -DEXCLUDE_SKIA_DEPENDENCIES -DOS_POSIX=1 -DOS_LINUX=1 -I/home/ncopa/aports/main/xulrunner/src/mozilla-release/content/base/public -I/home/ncopa/aports/main/xulrunner/src/mozilla-release/content/xml/document/src  -I/home/ncopa/aports/main/xulrunner/src/mozilla-release/ipc/chromium/src -I/home/ncopa/aports/main/xulrunner/src/mozilla-release/ipc/glue -I../../ipc/ipdl/_ipdlheaders  -I/home/ncopa/aports/main/xulrunner/src/mozilla-release/gfx/thebes -I. -I../../dist/include  -I/usr/include/nspr -I/usr/include/nss      -fPIC -Os -fomit-frame-pointer -pipe -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -pipe  -DNDEBUG -DTRIMMED -g -Os -freorder-blocks  -fomit-frame-pointer  -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15   -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15   -I/usr/include/pixman-1   -I/home/ncopa/aports/main/xulrunner/src/mozilla-release/widget/gtk2/compat -I/usr/include/gtk-unix-print-2.0 -I/usr/include/atk-1.0 -I/usr/include/harfbuzz -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/gdk-pixbuf-2.0 -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libpng15   -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -pthread -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15      -Os -fomit-frame-pointer -pipe -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MF .deps/gfxReusableSurfaceWrapper.o.pp  /home/ncopa/aports/main/xulrunner/src/mozilla-release/gfx/thebes/gfxReusableSurfaceWrapper.cpp
nsSurfaceTexture.cpp
/home/ncopa/aports/main/xulrunner/src/mozilla-release/gfx/thebes/gfxPlatform.cpp: In member function 'virtual mozilla::RefPtr<mozilla::gfx::SourceSurface> gfxPlatform::GetSourceSurfaceForSurface(mozilla::gfx::DrawTarget*, gfxASurface*)':
/home/ncopa/aports/main/xulrunner/src/mozilla-release/gfx/thebes/gfxPlatform.cpp:656:53: error: 'cairo_null_surface_create' was not declared in this scope
/home/ncopa/aports/main/xulrunner/src/mozilla-release/gfx/thebes/gfxPlatform.cpp:661:95: error: 'cairo_surface_attach_snapshot' was not declared in this scope
make[6]: *** [gfxPlatform.o] Error 1
make[6]: *** Waiting for unfinished jobs....
make[6]: Leaving directory `/home/ncopa/aports/main/xulrunner/src/mozilla-release/obj-i686-pc-linux-gnu/gfx/thebes'
make[5]: *** [libs] Error 2



Expected results:

build success
(Reporter)

Comment 1

5 years ago
Created attachment 759101 [details] [diff] [review]
cairo.patch

We have used this patch with success for some time.

Updated

5 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
(Reporter)

Comment 2

4 years ago
This appears to be fixed since firefox-24.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 722975
You need to log in before you can comment on or make changes to this bug.