Closed Bug 880217 Opened 6 years ago Closed 6 years ago

[MMS]'undefined' tag appears instead of MMS in thread list view

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla24
blocking-b2g leo+
Tracking Status
firefox22 --- wontfix
firefox23 --- wontfix
firefox24 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: isabelrios, Assigned: ctai)

References

Details

(Whiteboard: MMS_TEF[fixed-in-birch])

Attachments

(3 files)

Attached image 'undefined' label
Bug seen on Unagi v1-train
Gecko-65bbcee
Gaia-13c6246

PROCEDURE
1.Send a couple of MMSs
2.In message thread listing tag “MMS” appears
3.Send a SMS
4.Look at the thread list view
5.Then open the thread and Edit it removing the SMS
6.Go back to thread list view. 

ACTUAL
After the sms is removed, in the thread list view, it apperas 'undefined' instead of 'MMS' tag.

EXPECTED
The management of the tags should be correct, in any case 'undefined' should appear.
Let me correct the expected: The management of tags should be correct, 'undefined' should NOT appear under any circunstance.

Btw, the MMSs and SMS should be in the same thread, just in case it is not clear in the steps.
Blocking for now, MMS work.
blocking-b2g: leo? → leo+
Assignee: nobody → mike
I've traced this behavior back to the call to `navigator.mozMobileMessage.getThreads`. I'm attaching a patch that contains a debugging statement. If you follow the steps to reproduce, you will see that the thread's `lastMessageType` is not updated when the latest message in the thread is deleted.

Steve: I'm not sure if you are the right person to contact for this, but I thought you would know who could help.
Flags: needinfo?(schung)
Hi Mike, it looks like a gecko issue because the threadList returning from getThreads does not updated properly after message database changed. needinfo to Chia-Hung.
Flags: needinfo?(schung)
Flags: needinfo?(ctai)
Assignee: mike → ctai
Flags: needinfo?(ctai)
Attached patch Patch v1.0Splinter Review
Attachment #760763 - Flags: review?(gene.lian)
Component: Gaia::SMS → DOM: Device Interfaces
Product: Boot2Gecko → Core
Comment on attachment 760763 [details] [diff] [review]
Patch v1.0

Review of attachment 760763 [details] [diff] [review]:
-----------------------------------------------------------------

Nice catch!
Attachment #760763 - Flags: review?(gene.lian) → review+
https://hg.mozilla.org/projects/birch/rev/75be201c24a8
Keywords: checkin-needed
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Whiteboard: MMS_TEF → MMS_TEF[fixed-in-birch]
https://hg.mozilla.org/mozilla-central/rev/75be201c24a8
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Hi,

It is working fine on today's 1.1 build (tested on Unagi device):
gecko: b300478
gaia: 0c836be

so marking as VERIFIED. Thanks!
Status: RESOLVED → VERIFIED
Flags: in-moztrap?
Flags: in-moztrap?
You need to log in before you can comment on or make changes to this bug.