Searching an app by its full name is not displayed first in the Search Results page

VERIFIED FIXED in 2013-09-24

Status

Marketplace
Search
P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Iulian Timis, Assigned: robhudson)

Tracking

2013-09-24
x86_64
Windows 7
Points:
---

Details

(Whiteboard: [blocked on spec])

(Reporter)

Description

5 years ago
Steps to reproduce:
1. Load https://marketplace.allizom.org/
2. Search for an app by it's full name (ex. "Test App (bmw)") 

Expected results:
The app is displayed first in the Search Results page.

Actual results:
The searched app is displayed the 30th app in the list.

Notes/Issues:
Verified on FF24 (Win 7).
Screencast for this issue http://screencast.com/t/oXYkxg0YBGa
Summary: Searching an app by it's full name is not displayed first in the Search Results page → Searching an app by its full name is not displayed first in the Search Results page
Depends on: 572453
Whiteboard: [blocked on spec]

Comment 1

5 years ago
Also our automated test fail because apps that we search for are not in the list or "No results found"
See screencast: http://screencast.com/t/PpYsOviF8hM4

Comment 2

5 years ago
ID: 6fefa
(Assignee)

Comment 3

5 years ago
We should re-index on stage. The last time we tried I believe it failed and not all apps got indexed.
Priority: -- → P3
(Assignee)

Comment 4

5 years ago
We could do a boost on an exact match. We currently aren't doing this and it'd be a simple addition to our existing queries.
(Assignee)

Updated

5 years ago
Assignee: nobody → robhudson.mozbugs
(Assignee)

Comment 5

5 years ago
This adds an exact match boost.
https://github.com/mozilla/zamboni/commit/8248650

There are times when this still won't make the app first because of the way we boost apps based on popularity. If your query matches a newly submitted app exactly and also an app that is very popular (e.g. Twitter), the non-exact-match will be boosted higher than the exact match. But at least this should bump exact matches to the top for similarly popular apps.

To verify:
1. Create and approve 2 apps that are named similarly.
2. Search for one app using the exact name and verify it is above the 2nd app.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-09-24
(Reporter)

Comment 6

5 years ago
Verified as fixed inhttps://marketplace-dev.allizom.org/search?q=xyz1234 on FF27(Win 7).
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.