Make opening the browser debugger not freeze the debuggee/debugger UI as much

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [chrome-debug])

(Reporter)

Description

5 years ago
Apologies for the fuzzy description, but I've noticed that when I load the browser debugger, first the debuggee hangs for a bit, and then the debugger hangs for a bit. I'm guessing this is the data on loaded scripts being collected, sent, and then parsed and stuck into data structures on the other end. It would be very nice if that could be done in some kind of nicer version of (dare I say it) a setTimeout loop, so that the UI doesn't freeze on either side.
This is a recent regression, presumably ever since the introduction of source maps, that bug 873224 should greatly improve. My profiling shows that the main cause of the freezes is the garbage collector taking a very long time to clean up after a sudden burst of object creation and dismissal. I'll leave this bug open for further improvements after the other patch lands.
Depends on: 873224
Whiteboard: [chrome-debug]
We've recently fixed most of the performance issues here.
Priority: -- → P3
As Panos says, we've done a bunch of work on optimizing start up. Reopen if you have a specific test case that is still super slow.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.