JS::Anchor use is probably a gc hazard

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: bz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Pretty much by definition, any use of Anchor is a GC hazard when we move to exact rooting.  So they should really become Rooted.

The problem is, Rooted has a no-op destructor right now, so doesn't actually work to keep things alive in the stack-scanner world.  :(

I'm not quite sure what the right thing is here in terms of what the static analysis should do with Anchor...  Maybe it's enough to just replace Anchor with Rooted at the point at which we flip the stack scanner off, and assume that in the process no new hazards appear (since the use of Anchor implies the JS object is not used after the possibly-gc call).
(Assignee)

Updated

4 years ago
Assignee: general → nobody
No more conservative scanner, and no more Anchors anymore.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.