Closed Bug 880500 Opened 7 years ago Closed 6 years ago

symbolstore.py can hang when no symbols are found (mac)

Categories

(Toolkit :: Crash Reporting, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla24

People

(Reporter: twhitema, Assigned: twhitema)

Details

Attachments

(1 file)

The Mac symbol dumper splits into two requests - one to generate the symbols from a file (creates a .DSYM file), and a second to process those symbols.

The issue is that in ProcessFilesMacFinished() method, it always expects a "result['files']" object, so that it can notify that the process was finished. However, in the case of file that was missing symbols, the "result['files']" never gets populated - which causes a Python runtime exception and the whole symbol store process is then stuck waiting for this process that never finishes (or at least that it never reported it finished).
Attachment #759479 - Flags: review?(singerb.dev)
Comment on attachment 759479 [details] [diff] [review]
Handle files without symbols on the mac

Review of attachment 759479 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me; even with result['status'] == False, it still needs result['files'] to do the JobFinished.
Attachment #759479 - Flags: review?(singerb.dev) → review+
@benedict

Could you please push this into mozilla-inbound - as I don't have inbound (L3) permissions.
I don't have those permissions, but I've added the flag for this, and someone will do a sweep and push it soon.
Keywords: checkin-needed
For the record, although Benedict isn't actually a peer I'm fine with him granting this review since he wrote so much of this code.
https://hg.mozilla.org/mozilla-central/rev/5f32fc157fea
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
You need to log in before you can comment on or make changes to this bug.