Closed Bug 880592 Opened 6 years ago Closed 6 years ago

Wrong tab count after killed by OS and restored

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 24
Tracking Status
firefox22 --- unaffected
firefox23 + verified
firefox24 + verified
firefox25 + fixed

People

(Reporter: bnicholson, Assigned: capella)

References

Details

(Keywords: reproducible)

Attachments

(1 file)

STR:
1) Open two tabs
2) Select the first tab
3) Wait at least 10 seconds to ensure the session is written to disk
4) Press home
5) Cause Fennec to be killed in the background (either open lots of other apps or run oom-fennec)
6) Reopen fennec

After Fennec is reopened and the session restore, the tab count shows 1 even though two tabs are open.
Attached patch Patch (v1)Splinter Review
My bad ... regression caused by bug 874036
Assignee: nobody → markcapella
Status: NEW → ASSIGNED
Attachment #760180 - Flags: review?(lucasr.at.mozilla)
Blocks: 874036
Attachment #760180 - Flags: review?(lucasr.at.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/6ec3af901c39
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Blocks: 868222
Comment on attachment 760180 [details] [diff] [review]
Patch (v1)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): regression re: bug 874036
User impact if declined: Brief incorrect information displayed on restarts after OOM situations.
Testing completed (on m-c, etc.): Yes, STR as attached
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch: none
Attachment #760180 - Flags: approval-mozilla-beta?
(In reply to Mark Capella [:capella] from comment #4)
> Risk to taking this patch (and alternatives if risky): 

Risk evaluation, please :)
Flags: needinfo?(markcapella)
Sorry, not sure how I missed bugzilla mail with comment 5 ..

This and bug 874036 and bug 868222 (three as a package) are what I'd consider low risk in that they affect UI / displayed information only ... but, they prevent us (temporarily) displaying noticeably wrong information to users which of course is a good thing.

Changes are small and easily backed out, or more likely patched and moved forward in the event of further unseen regressions, though after baking for this long, I can't see that as a serious possibility.

The alternatives are limited, basically go without the fixes and expose wrong information to user scrutiny, or find another way of fixing the underlying problems in the current available time-frame.
Flags: needinfo?(markcapella)
Comment on attachment 760180 [details] [diff] [review]
Patch (v1)

Thanks Mark, go ahead with uplift.
Attachment #760180 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whiteboard: checkin-needed
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.