TEST-UNEXPECTED-FAIL | tests/test-dom.test on / emit | Test output exceeded timeout (60s).

RESOLVED FIXED

Status

Add-on SDK
General
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
This has happened fairly frequently in the last two pushes to the repository.

TEST-UNEXPECTED-FAIL | tests/test-dom.test on / emit | Test output exceeded timeout (60s).
Traceback (most recent call last):
  File "bin/cfx", line 33, in <module>
    cuddlefish.run()
  File "/builds/slave/test/addonsdk-poller/addon-sdk-496665ddc4f7/python-lib/cuddlefish/__init__.py", line 617, in run
    test_all(env_root, defaults=options.__dict__)
  File "/builds/slave/test/addonsdk-poller/addon-sdk-496665ddc4f7/python-lib/cuddlefish/__init__.py", line 397, in test_all
    test_all_packages(env_root, defaults)
  File "/builds/slave/test/addonsdk-poller/addon-sdk-496665ddc4f7/python-lib/cuddlefish/__init__.py", line 490, in test_all_packages
    env_root=env_root)
  File "/builds/slave/test/addonsdk-poller/addon-sdk-496665ddc4f7/python-lib/cuddlefish/__init__.py", line 937, in run
    pkgdir=options.pkgdir)
  File "/builds/slave/test/addonsdk-poller/addon-sdk-496665ddc4f7/python-lib/cuddlefish/runner.py", line 745, in run_app
    OUTPUT_TIMEOUT, test_name, parseable)
Exception: Test output exceeded timeout (60s).
TinderboxPrint:Jetpack<br/>229/0
(Reporter)

Comment 3

5 years ago
I'm able to reproduce this locally every single time I've tried to run cfx testall today, using a Nightly built from http://hg.mozilla.org/mozilla-central/rev/efbe547a7972
(Reporter)

Comment 4

5 years ago
I'm not sure why this is permanently timing out on my linux VM with the current Nightly build, but it's only intermittently failing on tbpl...

If I add a | console.log(window); | to that test, it logs "undefined" to the console.
(Reporter)

Comment 5

5 years ago
And, just for fun, I commented out "test on / emit", and then "test once" started timing out identically...
(Reporter)

Comment 6

5 years ago
Similarly, if I comment out "test on / emit" AND "test once", "test remove" times out.

If I comment out all of the tests in test-dom.js, the test suite progresses just fine.

Is anyone else able to reproduce this locally with the latest Nightly builds?

Comment 8

5 years ago
Commit pushed to integration at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/559fec67084c38aed19f811200bd2f595cd0c912
Bug 880619 - Disable test-dom.js because of frequent test failures. r=mossop

Comment 9

5 years ago
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/559fec67084c38aed19f811200bd2f595cd0c912
Bug 880619 - Disable test-dom.js because of frequent test failures. r=mossop
(Reporter)

Comment 10

5 years ago
And pushed to inbound: http://hg.mozilla.org/integration/mozilla-inbound/rev/264002f52216


Irakli, any chance you know why these would fail all of the sudden the way they are?
(Reporter)

Updated

5 years ago
Flags: needinfo?(rFobic)
https://hg.mozilla.org/mozilla-central/rev/264002f52216
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

5 years ago
Oops, forgot the [leave open]...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

5 years ago
Priority: -- → P2

Comment 13

5 years ago
Commit pushed to australis at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/559fec67084c38aed19f811200bd2f595cd0c912
Bug 880619 - Disable test-dom.js because of frequent test failures. r=mossop
clear need info
Flags: needinfo?(rFobic)
(Reporter)

Comment 15

5 years ago
Haven't seen this for a while, closing the bug.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.