onfocus() for input elements does not work on Linux

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
--
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Sivakiran Tummala, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Windows NT 5.0; U)
BuildID:    Linux2001-06-20-06

onfocus does not work for  input elements on Linux.
attached a testcase..

Reproducible: Always
Steps to Reproduce:
1.load the testcase (attached)
2.
3.

Actual Results:  the result should read --- "passed\npassed\npassed\n"

Expected Results:  the result reads as --- "failed\nfailed\nfailed\n"
(Reporter)

Comment 1

17 years ago
testcase:--do not know why created attachement cannot be seen..

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML>
<HEAD>
<TITLE></FONT></B>hinp018.html</TITLE>

<BODY>

<SCRIPT type="text/javascript">
     var foc = null;
</SCRIPT>

<P>
<FORM>
  <input onfocus="foc=1" type="text" name="text1" value="foo.">
</FORM>

<FORM id="form1" name="nothing" method="post" 
action="/ngdrive/cgi-bin/dont_do_a_thing.cgi">
  <input onfocus="foc=1" type="button" value="bar">
</FORM>

<FORM>
  <input onfocus="foc=1"  type="Checkbox" name="check2" value="foobar" checked> 
sometext here.
</FORM>
                  
                  

<SCRIPT type="text/javascript">

for (var i=0;i<3;i++) {
 var oVar=document.getElementsByTagName('INPUT')[i].focus();
  if (foc) {
     document.write("Passed" + "<BR>");
    } else {
    document.write("failed" + "<BR>");
  }

}

</script>
</BODY>
</HTML>

Comment 2

17 years ago
using this testcase it works for me (i see passed passed passed) in the
2001061520 win2k build. Is this regression? (no way to test with a current
nightly at the moment)
(Reporter)

Comment 3

17 years ago
on Linux Build ID--2001-06-20-06 this failed ...works fine on win2k.
(Assignee)

Comment 4

17 years ago
Worksforme on both Win2k and Linux.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

17 years ago
verified on linux for build 2001-07-09-08
marking as verified
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.