bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

unclickable scrollbar using overflow auto and pointer-events none

RESOLVED FIXED in mozilla25

Status

()

Core
Event Handling
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cka, Assigned: spohl)

Tracking

21 Branch
mozilla25
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 (Beta/Release)
Build ID: 20130409194949

Steps to reproduce:

check http://jsfiddle.net/NczQG/2/
click on scrollbar in the output box
try to drag the handle
click on scrollbar arrows


Actual results:

nothing, the scrollbar does not react to my clicks


Expected results:

scrollbar and content should have reacted to my clicks.
(Reporter)

Updated

5 years ago

Updated

5 years ago
Component: Untriaged → DOM: Events
Product: Firefox → Core
Component: DOM: Events → Event Handling
Why should the scrollbar respond to clicks in this testcase? It belongs to an element which is pointer-events:none. This bug looks invalid to me.
(Reporter)

Comment 2

5 years ago
because the user expects it to react.
either the scrollbar is here and the user can interact with it, or it should not be here.

we cannot set pointer-events on the scrollbar under firefox, so we can't "fix it"
If you don't want the scrollbar to appear, make the element overflow:hidden.
(Reporter)

Comment 4

5 years ago
sorry about the delay.
I do want the scrollbar to appear, but i still want clicks on content to fall through to other content below it.
Is this fixed in nightly builds for you on Windows? I think http://hg.mozilla.org/mozilla-central/rev/f8bf18dceb1c might have fixed it.
(Reporter)

Comment 6

5 years ago
yes ! it's fixed ! thanks a lot.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Assignee: nobody → spohl.mozilla.bugs
Depends on: 891136
Target Milestone: --- → mozilla25
You need to log in before you can comment on or make changes to this bug.