Loading web pages doesn't work

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: samuel.lauren, Unassigned)

Tracking

24 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130514193536

Steps to reproduce:

After opening Firefox I tapped the address bar, typed mozilla.org and pressed go.


Actual results:

Browser did not not navigate to the website. After pressing "go" the address bar lost its focus but the no new page was loaded. Problem appears regardless of the web page in question. Navigating to about: pages works correctly.


Expected results:

Browser should have navigated to the website.
Device? Build? OS? Keyboard?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(samuel.lauren)
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

5 years ago
Asus Nexus 7
24.01a (2013-06-07)
Android 4.2.2
Google stock keyboard (1.0.1869.683049) but the problem also appears with other keyboards I have tried

Also tapping any links produces similar behavior. If I open any web page and try to tap any links in it the browser won't navigate anywhere. This also happens with the Top sites thumbnails in the front page and for bookmarks. All these problems appeared after Nightly update couple of days ago.

However, if Firefox is started from some other application (Let's say I tap "Open in the browser" button in Feedly) it will navigate correctly to that web page. Also if I go to the Settings -> About Nightly page the links there (FAQ, Support, Privacy Policy, etc...) work.

I'm not sure if I should put those issues into their own bug report but I'm pretty sure the problems are related so...
Flags: needinfo?(samuel.lauren)

Updated

5 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
I have a Nexus 7 as well, running 4.2.2, everything stock. When I hit 'Go' after entering mozilla.org, I am taken to the website. Is there anything else modifying your setup, add-ons?
(Reporter)

Comment 4

5 years ago
Oh it turns out the culprit was NoScript 3.5a3rc201211032306. Disabling it solved the problem. I guess something must have changed that broke it.
Yikes, I suggest emailing giorgio@maone.net about that. Chances are other people running his Alpha (http://noscript.net/nsa/) have ran into it.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME

Comment 6

5 years ago
Should be fixed in http://noscript.net/nsa/latest thank you.
You need to log in before you can comment on or make changes to this bug.