If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash in mozilla::AudioBlockPanStereoToStereo

RESOLVED DUPLICATE of bug 880202

Status

()

Core
Web Audio
--
critical
RESOLVED DUPLICATE of bug 880202
4 years ago
4 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

24 Branch
All
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox23 unaffected, firefox24 affected)

Details

(Whiteboard: [blocking-webaudio-], crash signature)

(Reporter)

Description

4 years ago
It first showed up in 24.0a1/200130606. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8f9ba85eb61c&tochange=204de5b7e0a6
It's likely a regression from bug 878765.

Signature 	mozilla::AudioBlockPanStereoToStereo(float const* const, float const* const, float, float, bool, float* const, float* const) More Reports Search
UUID	18f47c4c-f80e-4c94-b98c-852a72130607
Date Processed	2013-06-07 15:32:25
Uptime	310
Install Age	5.2 minutes since version was first installed.
Install Time	2013-06-07 15:27:06
Product	Firefox
Version	24.0a1
Build ID	20130607031055
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 42 stepping 7
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x6c1f6000
App Notes 	
AdapterVendorID: 0x10de, AdapterDeviceID: 0x0e22, AdapterSubsysID: 350a1458, AdapterDriverVersion: 9.18.13.1422
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ WebGL? EGL? EGL+ GL Context? GL Context+ WebGL+ 
Processor Notes 	sp-processor03_phx1_mozilla_com_4806:2012; non-integer value of "SecondsSinceLastCrash"
EMCheckCompatibility	True
Adapter Vendor ID	0x10de
Adapter Device ID	0x0e22
Total Virtual Memory	4294836224
Available Virtual Memory	2789654528
System Memory Use Percentage	61
Available Page File	9678741504
Available Physical Memory	3277332480

Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::AudioBlockPanStereoToStereo 	content/media/AudioNodeEngine.cpp:116
1 	xul.dll 	mozilla::dom::PannerNodeEngine::GainStereoToStereo 	content/media/webaudio/PannerNode.cpp:326
2 	xul.dll 	mozilla::dom::PannerNodeEngine::EqualPowerPanningFunction 	content/media/webaudio/PannerNode.cpp:300
3 	xul.dll 	mozilla::dom::PannerNodeEngine::ProduceAudioBlock 	content/media/webaudio/PannerNode.cpp:136
4 	xul.dll 	mozilla::AudioNodeStream::ProduceOutput 	content/media/AudioNodeStream.cpp:428
5 	xul.dll 	nsRefPtr<mozilla::MediaStream>::nsRefPtr<mozilla::MediaStream> 	obj-firefox/dist/include/nsAutoPtr.h:904
6 	xul.dll 	mozilla::MediaStreamGraphImpl::ProduceDataForStreamsBlockByBlock 	content/media/MediaStreamGraph.cpp:967
7 	xul.dll 	mozilla::MediaStreamGraphImpl::RunThread 	content/media/MediaStreamGraph.cpp:1068
8 	nss3.dll 	PR_ExitMonitor 	nsprpub/pr/src/threads/prmon.c:100
9 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:626
10 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:264
11 	nss3.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:397
12 	nss3.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:90
13 	msvcr100.dll 	_callthreadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:314
14 	msvcr100.dll 	_threadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:292
15 	kernel32.dll 	BaseThreadInitThunk 	
16 	ntdll.dll 	__RtlUserThreadStart 	
17 	ntdll.dll 	_RtlUserThreadStart 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3AAudioBlockPanStereoToStereo%28float+const*+const%2C+float+const*+const%2C+float%2C+float%2C+bool%2C+float*+const%2C+float*+const%29
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 880202
Whiteboard: [blocking-webaudio-]
You need to log in before you can comment on or make changes to this bug.