Crash on exit with Java enabled.

VERIFIED DUPLICATE of bug 88053

Status

Core Graveyard
Java: OJI
--
major
VERIFIED DUPLICATE of bug 88053
17 years ago
8 years ago

People

(Reporter: edburns, Assigned: edburns)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

17 years ago
Visit java.sun.com with java installed and enabled.

Exit the browser. 

Here's a stack trace:

CJavaPluginView::PluginWndProc(HWND__ * 0x00010608, unsigned int 2, unsigned 
int 0, long 0) line 663 + 5 bytes
USER32! 77e7131f()
USER32! 77e71a3d()
NTDLL! 77f7637b()
nsWindow::~nsWindow() line 546
nsWindow::`scalar deleting destructor'() + 15 bytes
nsWindow::Release(nsWindow * const 0x02923744) line 425 + 167 bytes
nsCOMPtr<nsIWidget>::assign_assuming_AddRef(nsIWidget * 0x00000000) line 472
nsCOMPtr<nsIWidget>::assign_with_AddRef(nsISupports * 0x00000000) line 964
nsCOMPtr<nsIWidget>::operator=(nsIWidget * 0x00000000) line 584
nsXULWindow::Destroy(nsXULWindow * const 0x02927b84) line 396
nsWebShellWindow::Destroy(nsWebShellWindow * const 0x02927b84) line 1743 + 9 
bytes
nsChromeTreeOwner::Destroy(nsChromeTreeOwner * const 0x02923574) line 228
GlobalWindowImpl::ReallyCloseWindow(GlobalWindowImpl * const 0x029230e4) line 
2384
GlobalWindowImpl::CloseWindow(nsISupports * 0x029230d4) line 3152
nsJSContext::ScriptEvaluated(nsJSContext * const 0x02926eb0, int 1) line 1349 + 
18 bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x02926eb0, void * 
0x02c2af90, void * 0x02c2af98, unsigned int 1, void * 0x0012e81c, int * 
0x0012e818, int 0) line 949
nsJSEventListener::HandleEvent(nsJSEventListener * const 0x039126e0, 
nsIDOMEvent * 0x04f8c4d4) line 139 + 57 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x03912660, 
nsIDOMEvent * 0x04f8c4d4, nsIDOMEventTarget * 0x0376a6c8, unsigned int 8, 
unsigned int 7) line 1161 + 20 bytes
nsEventListenerManager::HandleEvent(nsEventListenerManager * const 0x03912730, 
nsIPresContext * 0x0314cd10, nsEvent * 0x0012f33c, nsIDOMEvent * * 0x0012f1e8, 
nsIDOMEventTarget * 0x0376a6c8, unsigned int 7, nsEventStatus * 0x0012f388) 
line 2131 + 36 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x0376a6c0, nsIPresContext * 
0x0314cd10, nsEvent * 0x0012f33c, nsIDOMEvent * * 0x0012f1e8, unsigned int 1, 
nsEventStatus * 0x0012f388) line 3635
PresShell::HandleDOMEventWithTarget(PresShell * const 0x0314dd30, nsIContent * 
0x0376a6c0, nsEvent * 0x0012f33c, nsEventStatus * 0x0012f388) line 5677 + 39 
bytes
nsMenuFrame::Execute() line 1424
nsMenuFrame::HandleEvent(nsMenuFrame * const 0x02b91848, nsIPresContext * 
0x0314cd10, nsGUIEvent * 0x0012f7e0, nsEventStatus * 0x0012f6d4) line 399
PresShell::HandleEventInternal(nsEvent * 0x0012f7e0, nsIView * 0x04f8abe0, 
unsigned int 1, nsEventStatus * 0x0012f6d4) line 5645 + 41 bytes
PresShell::HandleEvent(PresShell * const 0x0314dd34, nsIView * 0x04f8abe0, 
nsGUIEvent * 0x0012f7e0, nsEventStatus * 0x0012f6d4, int 0, int & 1) line 5557 
+ 25 bytes
nsView::HandleEvent(nsView * const 0x04f8abe0, nsGUIEvent * 0x0012f7e0, 
unsigned int 8, nsEventStatus * 0x0012f6d4, int 0, int & 1) line 377
nsView::HandleEvent(nsView * const 0x04f6fa70, nsGUIEvent * 0x0012f7e0, 
unsigned int 8, nsEventStatus * 0x0012f6d4, int 0, int & 1) line 350
nsView::HandleEvent(nsView * const 0x04f7fd30, nsGUIEvent * 0x0012f7e0, 
unsigned int 8, nsEventStatus * 0x0012f6d4, int 0, int & 1) line 350
nsView::HandleEvent(nsView * const 0x0314c450, nsGUIEvent * 0x0012f7e0, 
unsigned int 28, nsEventStatus * 0x0012f6d4, int 1, int & 1) line 350
nsViewManager::DispatchEvent(nsViewManager * const 0x0314c5f0, nsGUIEvent * 
0x0012f7e0, nsEventStatus * 0x0012f6d4) line 2051
HandleEvent(nsGUIEvent * 0x0012f7e0) line 68
nsWindow::DispatchEvent(nsWindow * const 0x04f7f4b4, nsGUIEvent * 0x0012f7e0, 
nsEventStatus & nsEventStatus_eIgnore) line 720 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f7e0) line 741
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 4237 
+ 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 
4486
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 14549036, long 
* 0x0012fc24) line 3203 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00010612, unsigned int 514, unsigned int 0, 
long 14549036) line 988 + 27 bytes
USER32! 7

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 88053 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.