Audio tag fails to play files with a period then letter in the name

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Michael, Unassigned)

Tracking

24 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130607 Firefox/24.0 (Nightly/Aurora)
Build ID: 20130607031055

Steps to reproduce:

After I found I was unable to play files like "D.T.m4a", but able to play "D.T.mp3", I tried the following test:
I tried playing MP3, OGG and M4A files with the following names:
test (e.g. test.mp3)
test. (e.g. test..mp3)
tes.t (e.g. tes.t.mp3)
tes.1 (e.g. tes.1.mp3)


Actual results:

All played successfully except for the M4A file with the name:
tes.t


Expected results:

The file should have played fine.
I made a page to test this at:
http://badgercode.co.uk/music
(Reporter)

Updated

5 years ago
(Reporter)

Comment 1

5 years ago
I believe this may be an Apache problem as that's what I use locally. The webserver I uploaded the test page to uses LightSpeed, and that works fine (although the built-in player disappears when I play a file in Nightly 24).

I've zipped the files up if anyone wants to test it to see if it's a localhost problem, or just an Apache problem
http://badgercode.co.uk/music/music.zip

Comment 2

5 years ago
It works, if you insert the following to mime_module section of httpd.conf. And restart Apache.
    AddType audio/mp4 .m4a
(Reporter)

Comment 3

5 years ago
Ah! Thank you so much. 
The source of this was really throwing me since all M4A files played fine on the webserver in both Firefox and Chrome, but only in Chrome on my local copy would the ones with the awkward names play.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.