Closed Bug 880976 Opened 7 years ago Closed 7 years ago

libyuv assembly code turned off for all non-sse4 targets

Categories

(Core :: WebRTC, defect)

24 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25
Tracking Status
firefox24 --- affected
firefox25 --- fixed

People

(Reporter: jesup, Assigned: jesup)

References

Details

(Keywords: perf, Whiteboard: [WebRTC],[blocking-webrtc-][webrtc-uplift])

Attachments

(1 file)

Dumping the gyp commandline on Android (and I'm sure B2G) shows that yuv_disable_asm=1 is being passed...  I suspect strongly it should only be passed if the target arch is x86 and there's no sse support.

The updated libyuv has support for disabling individual assembler opts by target arch; however our configure.in can still make the choice, so no changes should be needed when that lands after this is fixed.
Caused by landing bug 878476; the test for disabling it is broken on non-x86
Assignee: nobody → rjesup
Depends on: 878476
Whiteboard: [WebRTC] [blocking-webrtc-] → [WebRTC],[blocking-webrtc-][webrtc-uplift]
also, bug 878476 broke SSSE support on SSSE3 x86 machines as well (forgot the 'M' in HAVE_TOOLCHAIN_SUPPORT_MSSSE3)
Attachment #773117 - Flags: review?(ted)
Summary: libyuv assembly code turned off for all non-sse targets → libyuv assembly code turned off for all non-sse4 targets
Depends on: 878446
No longer depends on: 878476
Oops, my bad, iirc randall reminded me of that issue after bug 878446 (see comment there), but i totally forgot about it. Definitely needs uplift to 24/aurora.
Attachment #773117 - Flags: review?(ted) → review+
https://hg.mozilla.org/mozilla-central/rev/67c757885771
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.