nsAppShell::Init() is called in each process on Gonk

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: sotaro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Firefox OS on gonk create nsAppShell in each b2g/content proceees. And nsAppShell::Init() is called in each processes. Other functions seem to be called on only b2g process. At first time boot up since flashing rom, one content process call nsAppShell::Init() on root permission.

I am not sure if it is intentional.

I found this during debugging Bug 871485. Confirmed on v1.1 buri.
(Reporter)

Comment 1

6 years ago
justin, it expected behavior? InitGonkMemoryPressureMonitoring() is called in all content process and sometimes called by root permission.
Flags: needinfo?(justin.lebar+bug)
> InitGonkMemoryPressureMonitoring() is called in all content process

This is expected.

> and sometimes called by root permission.

I don't know what you mean by this.

I don't know if nsAppShell::Init() is supposed to be called in all content processes, but is there some reason that you think it shouldn't be?  You might want to look through the git log of that file to see who knows it better than me.
Flags: needinfo?(justin.lebar+bug)
(Reporter)

Comment 3

6 years ago
(In reply to Justin Lebar [:jlebar] from comment #2)
> > InitGonkMemoryPressureMonitoring() is called in all content process

I asked you a question because you added InitGonkMemoryPressureMonitoring() in nsAppShell::Init(). Do you expect InitGonkMemoryPressureMonitoring() is called in all content process?
> Do you expect InitGonkMemoryPressureMonitoring() is called in all content process?

Yes.
(Reporter)

Comment 5

6 years ago
(In reply to Justin Lebar [:jlebar] from comment #4)
> > Do you expect InitGonkMemoryPressureMonitoring() is called in all content process?
> 
> Yes.

Thanks. I just thought if it is expected in b2g process.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.