Assertion failure: "should have already reflowed the kid"

RESOLVED DUPLICATE of bug 880925

Status

()

RESOLVED DUPLICATE of bug 880925
5 years ago
5 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86_64
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 760174 [details]
testcase

With:
  user_pref("svg.text.css-frames.enabled", true);

Assertion failure: !(((kid)->GetStateBits() & ((nsFrameState(1) << (10)) | (nsFrameState(1) << (12)))) != 0) (should have already reflowed the kid), at /Users/jruderman/trees/mozilla-central/layout/svg/nsSVGTextFrame2.cpp:4834

layout/svg/nsSVGTextFrame2.cpp:4834
4834	    MOZ_ASSERT(!NS_SUBTREE_DIRTY(kid), "should have already reflowed the kid");

This assertion was added in bug 876831.
(Reporter)

Comment 1

5 years ago
Created attachment 760175 [details]
stack
I think the fix I'm working on for bug 880925 will also fix this one.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 880925
You need to log in before you can comment on or make changes to this bug.