If I add my addon to Firefox the Firefox->About menu gets broken

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: suki.venkat, Unassigned)

Tracking

21 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Installed the Firefox Addon MuLTiFlow from here:
https://addons.mozilla.org/en-us/firefox/addon/multiflow/

P.S. I am one of the owners of the addon, so if there is something I can do to the addon to stop making this happen, I can do that.



Actual results:

Firefox --> About menu gets broken, i.e., shows XML named entity declaration error (appropriate DTD doesn't load, probably).


Expected results:

Firefox --> About menu should have been intact.
As far as I can see this is reproducible on the previous versions of Firefox (19, 20), so it's not a regression.
You could ask for help on IRC Mozilla / addons channel.
If you solve your problem, please don't forget to get back and close this bug.

Updated

5 years ago
Component: Untriaged → Extension Compatibility
This is not the right place to track problems in add-ons. To get help and fix your issue, please either post in the forums (https://forums.mozilla.org/addons/) or the #extdev channel on Mozilla IRC (http://wiki.mozilla.org/IRC).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

5 years ago
I reported this as a security lapse in Firefox that allowed addons to modify its crucial menus by accident.
In any case I managed to fix my addon without anyone's help but it is nice to know the consequences in Firefox for a broader audience.
To fix this bug I had to just remove some lines from my chrome.manifest related to branding:

locale	branding en-US	chrome/locale/branding/
locale	branding de-DE	chrome/locale/branding/
...

content branding branding/

I suppose these are only required for the standalone and not for the addon..
You need to log in before you can comment on or make changes to this bug.