Can't access my profile page on AMO(Oops! We had an error.)

VERIFIED FIXED in 2013-07-04

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: littleflyingboy, Assigned: ngoke)

Tracking

unspecified
2013-07-04

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

I don't have a clue how this happened. Last activity on AMO was this: https://addons.mozilla.org/en-US/firefox/addon/hide-bookmarksbar/reviews/466914/


Actual results:

Can't access my profile page on AMO, the link is: 
https://addons.mozilla.org/en-US/firefox/user/littleflyingboy/

Got the following messages:
-----------------------------------------------------------
Oops! We had an error.

We'll get to fixing that soon.

You can try refreshing the page, or head back to the Add-ons homepage.
-----------------------------------------------------------
Thanks for filing.  Looks like it's actually happening to a lot of users (eg. https://addons.mozilla.org/zh-CN/firefox/user/dkgo/).  Error is "DoesNotExist: Addon matching query does not exist."  More info for devs at http://sentry.dmz.phx1.mozilla.com/addons/addons/group/12935/
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

5 years ago
Same here.

I created my account, and when you try to login, it just gives you the message "Oops! We had an error." 

Also tried re-setting my password but that still doesn't work and I also tested it across several browsers.

Can somebody please have a look at this, as I really want to use your service.

Thanks.

Dave
(Assignee)

Updated

5 years ago
Assignee: nobody → ngoke
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla/zamboni/commit/cac7459db7b562101ec22fd244df4fcf13564a9e

Well, this fixes it in a way. I think this patch caused it somehow:

https://github.com/mozilla/zamboni/commit/b9c626be9f1a768e3091b9679c80ec33405c7ff0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Target Milestone: --- → 2013-07-04

Comment 4

5 years ago
Verified as fixed inhttps://addons.mozilla.org/ on FF22 (Win 7).
Profiles can now be accessed.
Closing bug.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

5 years ago
Thanks guys :D
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.