caret jumps down after trying to enter text after a table

VERIFIED FIXED in mozilla0.9.5

Status

()

P3
normal
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: sujay, Assigned: mozeditor)

Tracking

Trunk
mozilla0.9.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand; need r)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I just showed this to Joe...

using 6/27 build of netscape

1) launch netscape
2) launch composer
3) insert default 2 x 2 table

notice a br gets added after the table and you'll see a caret
just below the table. so far so good.

4) now start entering text.

notice the caret jumps down one line and whatever text you're entering
is on this line that jumped down.

expected: the text and caret to be on the line directly below the table.

all platforms.

Comment 1

17 years ago
talked with Joe, he believes it is an easy fix, end result will be a better user 
experience when using tables

reviewed and approved
Keywords: nsBranch
Priority: -- → P3
Target Milestone: --- → mozilla0.9.3

Comment 2

17 years ago
moving to 1.0
Keywords: nsBranch
Target Milestone: mozilla0.9.3 → mozilla1.0
(Assignee)

Comment 3

17 years ago
095
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.5
(Assignee)

Comment 4

17 years ago
Created attachment 48872 [details] [diff] [review]
patch for editor/base/nsHTMLEditor.cpp
(Assignee)

Updated

17 years ago
Whiteboard: fix in hand; need r,sr

Comment 5

17 years ago
Comment on attachment 48872 [details] [diff] [review]
patch for editor/base/nsHTMLEditor.cpp

sr=kin@netscape.com
Attachment #48872 - Flags: superreview+

Updated

17 years ago
Whiteboard: fix in hand; need r,sr → fix in hand; need r
(Assignee)

Comment 6

17 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
I still see the same behavior in the 9-19 build.  It looks like what's going on
is this: When a table is inserted the initial <BR> in a blank page is moved
immediately below the table - but the cursor is placed before this <BR>.  Once a
user begins typing the cursor is placed after that <BR> thus the jumping cursor
effect.  If I complete the steps to reproduce I can then enter text after the
</TABLE> and before the </BR>.    
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

17 years ago
james, i thk u are using a branch build. I just tried the fix and it works fine 
on the trunk 0918. Pls close this bug if that's the case. Thx! 

Comment 9

17 years ago
Ahh yes indeed I am on a branch - need to climb back over to the trunk.  
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
Verified per Shrirang's confirmation
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.