[leo-pre-iot-br] label "just now" for call log is not localized

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
P1
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: dpalomino, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [leo-pre-iot-br])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Device: leo
buildid: 20130529095707 (brazilian variant)

In the call log, the tag "just now" for quite recently calls, is not localized. Being the device configured in English, it just appears "just now" and not the Portuguese equivalent.

Updated

5 years ago
blocking-b2g: leo? → leo+

Comment 1

5 years ago
looks like shared/locale/date properties files didn't set correctly.

Comment 2

5 years ago
Which gaia version are you testing?
Hi guys! I just tried it with latest Gecko and Gaia from master (Gecko-c083ae2.Gaia-66e6719) and it reproduces.

The problem is the locale codes or properties we are using. Please, have a look at https://github.com/mozilla-b2g/gaia/blob/master/shared/locales/date/date.en-US.properties#L166 and https://github.com/mozilla-b2g/gaia/blob/master/shared/locales/date/date.fr.properties#L117 The Gaia code uses the 'en-US' version so I am updating all the related locales codes to this format.
Assignee: nobody → gtorodelvalle
Created attachment 762607 [details]
Associated PR.

Additional note for the L10N guys: I also found more differences between the en-US locale file and the others. More concretely, all the 'weeks-ago-long', 'months-ago-long', 'years-ago-long', 'weeks-until-long', 'months-until-long' and 'years-until-long' entries only appear in the en-US version and not on the ar, fr or zh-TW locales. I guess this should be synchronized.
Attachment #762607 - Flags: review?(francisco.jordano)
Flags: needinfo?(l10n)

Comment 5

5 years ago
Comment on attachment 762607 [details]
Associated PR.

The localized files inside the gaia git repository are just for developers, they're not used for the actual builds.

I see little value in maintaining them in parts.

The real localizations come out of the repositories in http://hg.mozilla.org/gaia-l10n/ or their respective git mirrors.
Attachment #762607 - Flags: review?(francisco.jordano) → review-

Updated

5 years ago
Flags: needinfo?(l10n)
Thanks Axel! Does it mean you will take care of updating whatever it is necessary in http://hg.mozilla.org/gaia-l10n/ based on my patch or should I take care of it? Thanks!

Comment 7

5 years ago
Your patch likely wouldn't apply. I'll wait for the localizers to take care of the strings.
This is a one-off localized bug that I saw a few days back and blocked on it thinking it missed translation.But,after getting in touch with the L10n team recently I have come to know that they are not localization complete for Pt-Br locale and so ideally this does not qualify as a blocker yet.Unsetting the flag.
blocking-b2g: leo+ → ---

Updated

5 years ago
Priority: -- → P1
Just pointing out that it won't work in any language but English since the locale strings (properties) are wrong in those locale files ;-)
Leaving the bug as unassigned since not currently working on it...
Assignee: gtorodelvalle → nobody
We verified that this is fixed on the lock screen, but we don't use this string anymore within the Dialer.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.