hdpi/xhdpi resolution assets and layout for Bluetooth File Transfer app

VERIFIED FIXED

Status

Firefox OS
Gaia::Bluetooth
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: timdream, Assigned: iliu@mozilla.com, ianliu.moz@gmail.com)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:hd+, b2g-v1.1hd fixed)

Details

Attachments

(2 attachments)

This bug represents fixes needed in Bluetooth File Transfer app in order to deliver bug 881126:

-- Have visual supply us with @1.5x and the correct @2x images.
-- On v1.1hd, modify CSS/JS so that apps will display @1.5x/@2x images correctly.
-- On master, drop the @1.5x and @2x images and make sure there is no
more to tweak besides changes made on bug 830644.

As HIDPI support never landed on v1-train, I expect the patch for both
branches on this bug will be different. The CSS/JS patch on v1.1hd will be based on the patch on master, but I won't expect it to be as simple as a |git cherry-pick|; so this is
where the engineering work lays.

The patch on top of v1-train should land on v1.1hd.
Setting hd+ for 1.1hd specific requirement
blocking-b2g: hd? → hd+
Ian do you have time for this?
Assignee: nobody → iliu
Yeah, I'm able to take care of it.
Created attachment 770056 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10736

Pointer to Github pull-request
Comment on attachment 770056 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10736

WIP for 1.1.0hd

Before kicking off reviewing I'd like to confirm things about review process:

1.What I added to this patch include css changes and @1.5x assets shrunk from @2x assets in master. These @1.5x assets are not the final version, and they are here just to confirm we have correct layout on HD devices. They should be replaced by newly drawn assets supplied by visual team later.

2. We need to test whether this patch work on HVGA(320x480), WVGA(480x800). Should we test for qHD(960x540) at this time too? We don't have appropriate devices on hand so this can only be confirmed using desktop / nightly.

3. If reviewer don't have HD devices, we may need to put some screenshot (specified by reviewer?) here to confirm whether we left something.
Comment on attachment 770056 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10736

WIP for 1.1.0hd

This bug aims to achieve similar goal with bug 830644 on hd1.1.0 branch.
Since we need some specified step to try on WVGA device (partial can be tested
on Nightly), if you care about the changes and would like to do a full review,
you may set review flag after reviewing; otherwise, you may set feedback flag
and let me find an appropriate reviewer in Taipei to review and confirm on WVGA
device.
These 1.5x assets in patch are here temporarily for confirming we're making right
layout changes, and will be replaced later after visual team supplied newly made
1.5x assets.
The step for testing in HD device / Nightly is noted in Github comment.

Thanks a lot! Feel free to ping me if you have any concerns.
Attachment #770056 - Flags: review?(rexboy)
Comment on attachment 770056 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10736

r=me, if comments on Github are solved.
Thanks for the patch!
Attachment #770056 - Flags: review?(rexboy) → review+
Created attachment 771243 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10789

Pointer to Github pull-request
Comment on attachment 771243 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10789

The pr cherry-pick from pr 10736(https://github.com/mozilla-b2g/gaia/pull/10736). It also be revised according to your comment. Please help to review it for master. Thanks.
Attachment #771243 - Flags: review?(rexboy)
(In reply to KM Lee [:rexboy] from comment #7)
> Comment on attachment 770056 [details]
> Pointer to Github pull request:
> https://github.com/mozilla-b2g/gaia/pull/10736
> 
> r=me, if comments on Github are solved.
> Thanks for the patch!

I have revised the pr and left comment on Github. Thanks for your reviewing effort again.
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Comment on attachment 771243 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10789

r=me

thanks!
Attachment #771243 - Flags: review?(rexboy) → review+
Thanks for Rex's reviewing effort. Since the prs are landed, we can close the issue now.

master:    72d5f703e45cdf522b37a8f46a18dcd40778a750
v1.1.0hd:  b92f6efda0f60cb7c90d99263234ad92dfb5013a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g-v1.1hd: --- → fixed
Resolution: --- → FIXED

Comment 13

5 years ago
[2013/10/21 Helix Testing]
Gaia:     c829a2042594b6c3a4899ee27979799a0f301534
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/f7c657f6d019
BuildID   20131015042201
Version   18.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.