Lots of IPCs caused by mozilla::dom::PContentChild::SendScriptError

RESOLVED DUPLICATE of bug 795534

Status

()

Core
IPC
RESOLVED DUPLICATE of bug 795534
5 years ago
5 years ago

People

(Reporter: Ting-Yuan Huang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
When opening Twitter on Firefox OS, script errors are repeatedly detected and sent to parent process for logging. Unfortuanately, many of the errors occured in extremely long lines. There are about 34 MBytes sent when opening Twitter, although parent process cuts it off before printing it out. Anyway, it puts unecessary overheads to IPCs. Should we put some limitations on the erring source lines sent or just not show them?
(Reporter)

Comment 1

5 years ago
Hi Kyle and Justin, any comments? I'd like to cut the lines off earlier in ConsoleListener::Observe()
Flags: needinfo?(khuey)
Flags: needinfo?(justin.lebar+bug)
(In reply to Ting-Yuan Huang from comment #1)
> Hi Kyle and Justin, any comments? I'd like to cut the lines off earlier in
> ConsoleListener::Observe()

We've had lots of problems with the console listener sending very long messages.  Go for it.
Flags: needinfo?(justin.lebar+bug)
(In reply to Justin Lebar [:jlebar] from comment #2)
> (In reply to Ting-Yuan Huang from comment #1)
> > Hi Kyle and Justin, any comments? I'd like to cut the lines off earlier in
> > ConsoleListener::Observe()
> 
> We've had lots of problems with the console listener sending very long
> messages.  Go for it.

+1
Flags: needinfo?(khuey)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795534
You need to log in before you can comment on or make changes to this bug.