Closed Bug 881195 Opened 7 years ago Closed 7 years ago

[Buri][Setting] WIFI status not correctly displayed if setting application was killed to relaunch

Categories

(Firefox OS Graveyard :: Wifi, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sync-1, Assigned: chenxk)

Details

Attachments

(2 files, 2 obsolete files)

AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.131
 Firefox os  v1.0.1
 Mozilla build ID:20130606070202
 
 Created an attachment (id=427828)
 screenshot
 
 connect the ME to a WIFI, see WIFI connection successful.
 
 use the ME for a while, open for example Contacts, Dialer, Browser, Camera.
 then come back to launch Settings, u can see Setting re-initiating (coz low RAM leads to Setting app being killed). however u find WIFI is offline, which differs from status bar.
 
 Expected:
 Setting should examine status before display it
 
 Suggest:
 Show nothing before get the wifi desc, just like the Call Settings, Cellular & Data and Bluetooth. 
 		
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Clone from brother
Attached image screenshot
Clone from brother
Dear Vincent,

There will be 2~4 seconds delay when initializing Settings. But I don't think it's proper to show "offline" by default, cuz it will lead some confusion(status bar show connected but Settings show 'offline' just like the attanchment) for users.
Could you have a look at this? Thank you.
Flags: needinfo?(vchang)
Dear Fabien,
Could you have a look at this? Thank you.
Attachment #761853 - Flags: review?(kaze)
Flags: needinfo?(vchang)
Flags: needinfo?(kaze)
Attachment #761853 - Attachment is obsolete: true
Attachment #761853 - Flags: review?(kaze)
Attachment #761949 - Flags: review?(kaze)
Attachment #761949 - Attachment is obsolete: true
Attachment #761949 - Flags: review?(kaze)
Attachment #761952 - Flags: review?(kaze)
Comment on attachment 761952 [details] [diff] [review]
delete the default value of wifi status in the html file

Good catch. Please needinfo’ me if you need me to merge your patch.
Attachment #761952 - Flags: review?(kaze) → review+
Flags: needinfo?(kaze)
Flags: needinfo?(kaze)
Merged on master: 071803d
https://github.com/mozilla-b2g/gaia/commit/071803db7c3c487b175fb19b637b18b12d59eff7
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(kaze)
Resolution: --- → FIXED
Assignee: nobody → chenxk
You need to log in before you can comment on or make changes to this bug.