Closed Bug 881264 Opened 7 years ago Closed 7 years ago

webgl ThreeJS renderer is black

Categories

(Core :: Canvas: WebGL, defect)

24 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla24
Tracking Status
firefox23 --- unaffected
firefox24 + verified

People

(Reporter: vagrant.deus, Assigned: dzbarsky)

References

()

Details

(Keywords: regression, reproducible)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130605070403

Steps to reproduce:

visit http://threejs.org/examples/webgl_buffergeometry_particles.html


Actual results:

webgl  three js renderer not show
OS: Windows 7 → Android
Hardware: x86_64 → ARM
in android 4.0.3 on acer iconia tab A100
[11:13:41.063] NS_ERROR_FAILURE: Failure @ http://threejs.org/build/three.min.js:418

The demo requires an extension not currently supported in Firefox for Android: compressed texture S3TC.

http://www.doesmybrowsersupportwebgl.com/
needinfo to bjacob regarding status of mobile + S3TC
Flags: needinfo?(bjacob)
Application Basics
------------------

Name: Fennec
Version: 24.0a1
User Agent: Mozilla/5.0 (Android; Tablet; rv:24.0) Gecko/24.0 Firefox/24.0

Extensions
----------

Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 204800
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.disk.smart_size_cached_value: 143360
browser.startup.homepage_override.mstone: 24.0a1
extensions.lastAppVersion: 24.0a1
network.cookie.prefsMigrated: true
storage.vacuum.last.index: 0

Graphics
--------

Adapter Description: NVIDIA Corporation -- NVIDIA Tegra -- OpenGL ES 2.0 14.01002 -- Model: A100, Product: a100_ww_gen1, Manufacturer: Acer, Hardware: vangogh
Device ID: NVIDIA Tegra
Driver Version: OpenGL ES 2.0 14.01002
GPU Accelerated Windows: 1/1 OpenGL (OMTC)
Vendor ID: NVIDIA Corporation
WebGL Renderer: NVIDIA Corporation -- NVIDIA Tegra
windowLayerManagerRemote: true
AzureCanvasBackend: cairo
AzureContentBackend: none
AzureFallbackCanvasBackend: none

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10
Version in use: 4.10

NSS
Expected minimum version: 3.15 Basic ECC
Version in use: 3.15 Basic ECC

NSSSMIME
Expected minimum version: 3.15 Basic ECC
Version in use: 3.15 Basic ECC

NSSSSL
Expected minimum version: 3.15 Basic ECC
Version in use: 3.15 Basic ECC

NSSUTIL
Expected minimum version: 3.15
Version in use: 3.15
(In reply to Aaron Train [:aaronmt] from comment #2)
> [11:13:41.063] NS_ERROR_FAILURE: Failure @
> http://threejs.org/build/three.min.js:418
> 
> The demo requires an extension not currently supported in Firefox for
> Android: compressed texture S3TC.
> 
> http://www.doesmybrowsersupportwebgl.com/

but in beta ? the  demo is fonctional
Component: General → Canvas: WebGL
Product: Firefox for Android → Core
Version: Firefox 24 → Trunk
Someone could repro on an Atrix 4G, confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
S3TC is supported by the browser on Android too wherever the GPU supports it... the problem is that the majority of mobile GPUs do /not/ support S3TC!

Specifically, as far as I know (used to be true at least around last year), the only mobile GPUs supporting S3TC are NVIDIA Tegras, and the reason why they do is that they are essentially cut-down versions of NVIDIA desktop GPUs.

Unfortunately there is no compressed texture format that is universally supported on all current mobile GPUs. We support S3TC, ATC and PVRTC at the moment, which covers most of the market (we miss some ARM Mali's I think, but most of the current ones do not support _any_ compressed format _with alpha_ --- ETC1 lacks alpha, which makes it largely useless). In the future, the mobile world is set to converge to a universal format like ETC2 or ASTC, but until the majority of mobile GPUs in the real world support those, we won't have any good solution.
Flags: needinfo?(bjacob)
...wait, the device in comment 4 *is* a Tegra. If this doesn't support S3TC, then I don't know why --- could we have a regression? We definitely used to have S3TC working on Android Tegra devices even recently.
Can we please get a regression window?
I did all the maj until Friday, Saturday and Sunday I was not working I made ​​the shift available today around 14h
(In reply to Aaron Train [:aaronmt] from comment #2)
> [11:13:41.063] NS_ERROR_FAILURE: Failure @
> http://threejs.org/build/three.min.js:418
> 
> The demo requires an extension not currently supported in Firefox for
> Android: compressed texture S3TC.
> 
> http://www.doesmybrowsersupportwebgl.com/

I now think that that's a red herring: go to about:config, set webgl.disable-extensions to true, retry: the demo still works on my desktop. So it doesn't rely on any WebGL extensions like S3TC textures.

We need to understand where that NS_ERROR_FAILURE is actually coming from.
 this 2013-06-09-03-12-30-mozilla-central-android/	09-Jun-2013 05:17 	
http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2013-06-09-03-12-30-mozilla-central-android/fennec-24.0a1.multi.android-arm.apk
 is functionnal  	 the lasted nigtnly is not functional  

for me having looked into the code of three will have a js error detection  Operation with the pixel ratio for canvas
you change something in the detection of the screen size or canvas size ?
2013-06-10-03-11-47-mozilla-central-android/	10-Jun-2013 05:24    bug
latest-mozilla-central-android/	10-Jun-2013 04:30 	bug
tracking-fennec: --- → ?
On Windows:
[14:48:55,237] NS_ERROR_FAILURE: Failure @ http://threejs.org/build/three.min.js:418
No error in 23.0a2 and below.
tracking-fennec: ? → ---
OS: Android → All
Hardware: ARM → All
Version: Trunk → 24 Branch
Keywords: reproducible
Summary: webgl ThreeJS renderer not show on last android nightly → webgl ThreeJS renderer is black
Probably related to bug 881681.
Depends on: 881681
passing it on to :dz to help with investigation as this could be related to the landing in Bug 881681 .

Please feel free to reassign if needed.
Assignee: nobody → dzbarsky
I can't reproduce this.  Is it still an issue?
Flags: needinfo?(vagrant.deus)
Excellent work, this seems to be resolved now. I've tested a few of AlteredQualia's demos without running into the bug.
Flags: needinfo?(vagrant.deus)
Fixed by https://hg.mozilla.org/mozilla-central/rev/57b06e8e2222.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.