Crash in @ JSC::Yarr::Interpreter<wchar_t>::matchDisjunction when previewing with Stylish

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: jason.barnabe, Unassigned)

Tracking

({crash, regression})

21 Branch
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox21 affected, firefox22 affected, firefox23 affected, firefox24 affected)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Updated

5 years ago
Keywords: crash

Comment 1

5 years ago
It first showed up in 21.0a1/20130213 but is discontinuous across builds. The regression range might be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=36525224b14e&tochange=161a347bda5b
Crash Signature: [@ JSC::Yarr::Interpreter<wchar_t>::matchDisjunction(JSC::Yarr::ByteDisjunction*, JSC::Yarr::Interpreter<wchar_t>::DisjunctionContext*, bool) ] [@ @0x0 | JSC::Yarr::Interpreter<wchar_t>::matchNonZeroDisjunction(JSC::Yarr::ByteDisjunction*, JSC::Yarr::Int…
status-firefox21: --- → affected
status-firefox22: --- → affected
status-firefox23: --- → affected
status-firefox24: --- → affected
Keywords: regression, regressionwindow-wanted
Hardware: x86_64 → x86

Comment 2

5 years ago
I tried with FF24 on Win 7, I don't crash.

Can the reporter test with a fresh profile and only Stylish+this style? (or post directly here)
Flags: needinfo?(jason.barnabe)

Comment 3

5 years ago
I'm the person that reported the issue on userstyles.org.  I did attempt to reproduce it with a new profile.

Good news.  Bad news.

First the good news.  I created a new profile and tried to reproduce it as requested.  I was not successful.

Now for the bad news.  Because it didn't happen every time, I can't be sure it would happen if I had tried it just one more time.  It is always very random.  Sometimes it is constant.  But the other day I was able to preview a style numerous times with no issue.  I have found that while killing the thread at first seemed to do better than continuing it, that difference has almost vanished.  I have some at least a little better reliability when I let the run for a moment before I kill it.
Flags: needinfo?(jason.barnabe)

Comment 4

5 years ago
Something I just thought of: Could it be trying to kill a thread that isn't running anymore?

Comment 5

5 years ago
I can't reproduce the issue with Firefox 22.  Did a patch already land in the release build?

Comment 6

5 years ago
Anyway it was already hard to reproduce it.

Comment 7

5 years ago
Happened with Firefox 25, same pattern: responding "continue" to a "do you want to continue this script" question box.

Comment 8

5 years ago
And here I was hoping I had a fix. :(
This Yarr crash is no longer relevant we removed Yarr in Firefox 32 (bug 976446).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: regressionwindow-wanted
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.