The default bug view has changed. See this FAQ.

Permanent Orange: TEST-UNEXPECTED-FAIL | test-retest-config.js::test_re_test_config

RESOLVED FIXED in Thunderbird 25.0

Status

Thunderbird
Account Manager
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

(Blocks: 1 bug, {intermittent-failure})

Trunk
Thunderbird 25.0
intermittent-failure

Thunderbird Tracking Flags

(thunderbird24+ fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

4 years ago
Since some time ago, we have been getting this on trunk:

https://tbpl.mozilla.org/php/getParsedLog.php?id=23957929&tree=Thunderbird-Trunk

TEST-START | /Users/cltbld/talos-slave/test/build/mozmill/account/test-retest-config.js | test_re_test_config
Step Pass: {"function": "controller.click()"}
Test Failure: Timeout waiting for modal dialog to open.
TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/mozmill/account/test-retest-config.js | test-retest-config.js::test_re_test_config

I've not yet found a way to reproduce it - it works fine for me locally, even when I try a packaged tests debug build.
(Assignee)

Updated

4 years ago
Keywords: intermittent-failure

Comment 1

4 years ago
Created attachment 761101 [details] [diff] [review]
WIP patch

Can you please run this on the try servers?
Assignee: nobody → acelists
Status: NEW → ASSIGNED
Attachment #761101 - Flags: feedback?(mbanner)

Comment 2

4 years ago
Mozmill tests are enough.
(Assignee)

Comment 3

4 years ago
Comment on attachment 761101 [details] [diff] [review]
WIP patch

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=29103dea3376
Attachment #761101 - Flags: feedback?(mbanner)

Comment 4

4 years ago
For reference, the failure starts first at checkin https://tbpl.mozilla.org/?tree=Thunderbird-Trunk&rev=72bf76257a34 , together with other failures. Looks like something changed in mozilla-central. I fixed the other ones (customize dialog), as the problem was that it looks like it no longer is possible to wait_for_new_window() via a window element ID, but windowType must be used. Maybe something similar needs to be done here too.
(Assignee)

Comment 5

4 years ago
That would give a regression range of approximately:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c21ef3664c67&tochange=00b264c7cced

(the nightly builds tend to have the logs kept for longer).

Note there are a couple of checkins relating to modal window changes at the bottom of that block.

A bit strange about the window id, not sure why I wouldn't be able to reproduce that locally.

Comment 6

4 years ago
And the window is not modal on any platform so I changed to wait_for_new_window() in the patch but still no success.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

4 years ago
Keywords: intermittent-failure
(Assignee)

Comment 9

4 years ago
(please keep the intermittent-failure annotation, even for permanent oranges, as this is required so that tbpl can pick it up and offer it as an orange option).
Keywords: intermittent-failure
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 16

4 years ago
Created attachment 766320 [details] [diff] [review]
patch v2

This would need a try run again.
Attachment #761101 - Attachment is obsolete: true
Attachment #766320 - Flags: feedback?(mbanner)
https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=6a41642b8fd9
(Assignee)

Comment 18

4 years ago
Oh interesting, I've just been running with this patch. Standalone the test passes, but run in alongside the rest of them in the directory, it fails.
(Assignee)

Comment 19

4 years ago
Created attachment 769620 [details] [diff] [review]
The fix

Ok, now I can reproduce it, that makes it easier.

What I found was that stopping test-mail-account-setup-wizard.js running 'fixed' the test.

In test-mail-account-setup-wizard.js it is opening up the account wizard as well. There's also some mc.sleep(0) statements in there.

I think what is happening is when the dialog closes, the stack isn't getting a chance to unwind before we try to open it again. Hence, this adds an additional sleep to test-retest-config.js which fixes the issue locally for me.

I've also pushed this to try server:

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=39a46ba37b01

Aceman: I think this is simple enough that you can review it.
Assignee: acelists → mbanner
Attachment #766320 - Attachment is obsolete: true
Attachment #766320 - Flags: feedback?(mbanner)
Attachment #769620 - Flags: review?(acelists)

Comment 20

4 years ago
So do we leave the modal dialog waiting in (even thought it is not modal) and just add this sleep?
(Assignee)

Comment 21

4 years ago
The sleep is enough to fix the tests (as demonstrated by try :-) ). We could fix it to be non-modal, but we should fix the other file at the same time, and I think that would probably be best done in a separate bug so that its clear what the fix for this bug is.

Updated

4 years ago
Blocks: 889000

Comment 22

4 years ago
Comment on attachment 769620 [details] [diff] [review]
The fix

Review of attachment 769620 [details] [diff] [review]:
-----------------------------------------------------------------

I got the failure randomly on my machine but I didn't get it since applying the patch. So let's try to land this.
Attachment #769620 - Flags: review?(acelists) → review+
(Assignee)

Comment 23

4 years ago
https://hg.mozilla.org/comm-central/rev/f878ff74a85a
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 25.0
(Assignee)

Comment 24

4 years ago
Comment on attachment 769620 [details] [diff] [review]
The fix

[Triage Comment]
All passing on trunk now, so lets get this on aurora.
Attachment #769620 - Flags: approval-comm-aurora+
(Assignee)

Comment 25

4 years ago
https://hg.mozilla.org/releases/comm-aurora/rev/a7b8008b37c7
status-thunderbird24: --- → fixed
You need to log in before you can comment on or make changes to this bug.