Add History Sidebar toggle item to History widget panel

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: shorlander, Assigned: tetsuharu)

Tracking

Trunk
Firefox 29
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M-])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Since we are removing the dedicated History sidebar toggle button we need a place to activate this sidebar besides the traditional menu.
Blocks: 879388
It's still toggable via menu and keyboard shortcut, so it's not clear to me that we need a widget for this at all. (I'd assume most people either leave it open, or can use the new History widget instead.)
Whiteboard: [Australis:M?] → [Australis:M-]
Duplicate of this bug: 879388

Comment 3

5 years ago
(In reply to Justin Dolske [:Dolske] from comment #1)
> It's still toggable via menu and keyboard shortcut, so it's not clear to me
> that we need a widget for this at all. (I'd assume most people either leave
> it open, or can use the new History widget instead.)

So you are now deciding how users have to work?!

Where is the problem to provide 2 simple icons (Bookmarks, History) which users can choose or not choose to use? Explain that to me!

Comment 4

5 years ago
The duped bug 879388 was for both History AND Bookmarks. Therefore, please add "Bookmarks" to this bug's Summary.
(In reply to Peter Lairo from comment #4)
> The duped bug 879388 was for both History AND Bookmarks. Therefore, please
> add "Bookmarks" to this bug's Summary.

bookmarks sidebar has a toogle in the Bookmarks widget already.

Comment 6

5 years ago
(In reply to Marco Bonardo [:mak] from comment #5)
> bookmarks sidebar has a toogle in the Bookmarks widget already.

The duped bug 879388 was about BUTTONS, and not some menu-item buried in a hard to find and even harder to hit thin sliver on the edge of another button. I think users who use the sidebar want a proper button for BOTH History AND Bookmarks.

Comment 7

5 years ago
(In reply to Peter Lairo from comment #6)
> (In reply to Marco Bonardo [:mak] from comment #5)
> > bookmarks sidebar has a toogle in the Bookmarks widget already.
> 
> The duped bug 879388 was about BUTTONS, and not some menu-item buried in a
> hard to find and even harder to hit thin sliver on the edge of another
> button. I think users who use the sidebar want a proper button for BOTH
> History AND Bookmarks.

This is exactly right (I'm the person who filed bug 879388).

The item in the Bookmarks widget is not an equivalent replacement. I switch between Bookmarks & History sidebar frequently, so having to click another menu icon just to reach the icon that I (frequently) want is definitely no improvement.

Sure I could use Ctrl-B and Ctrl-H, but is that an improvement? No.

Why does it harm to provide these icons in the customization panel? They don't have to be on the UI by default, I just want them to be available in order to allow for the same amount of customizability as is possible with the current UI.
Imo, any request for buttons to toogle sidebars or toolbars should be wontfixed. Firefox must keep core features that benefit most of our users, extensions allow to do anything else. Making an add-on to add such buttons seems trivial and only a few users have the need for them. That completely satisfies the request without the need to add tens of buttons for each small thing.

Comment 9

5 years ago
(In reply to Marco Bonardo [:mak] from comment #8)
> That completely
> satisfies the request without the need to add tens of buttons for each small
> thing.

What would be bad about it? Is customizability a bad thing now (only because Google Chrome is not customizable?)? Is the cost (performance, maintenance, ...) of a button so high that it has benefits which outweighs the benefits of customizability (I can't really imagine that)?

> Firefox must keep core features that benefit most of our users

Having a sidebar easily accessible is a core feature IMO.

Again, it seems to me like only because Google Chrome doesn't have a sidebar, a sidebar is suddenly not important anymore. What's next? The removal of the sidebar altogether? You could justify the removal of the sidebar with the same argument.

I said it many times before and I will say it again and again: Google Chrome is a BAD example for user interface, and to copy Chrome's UI is the worst thing you can do. Firefox has currently a much superior UI, and things like this definitely reduce this advantage significantly.
Please, remember this is a bug tracker, not a discussion forum nor an advocacy board.  In the firefox-dev mailing list there's already an open thread about this subject.
Fwiw, I think your j'accuse is very un-polite and very bad targeted.  I clearly expressed my reasoning, I totally don't care about other browsers reasons.  I must ask you to respect out netiquette.

Comment 11

5 years ago
What exactly was unpolite?

You are totally ignoring my arguments why this is a regression (worse than previous versions), and therefor a legitimate bug report. The place for legitimate bug reports is the bug tracking system. So everything is at its perfectly correct place here.

I just want my Firefox to be at least equally good as it is now, that's all. And I'm by far not the only user having issues with Australis, there are many complaints even though most Firefox users haven't even seen Australis yet (so expect many more complaints once it hits a wider audience).
(In reply to Marco Bonardo [:mak] from comment #10)
> Please, remember this is a bug tracker, not a discussion forum nor an
> advocacy board.  In the firefox-dev mailing list there's already an open
> thread about this subject.
> Fwiw, I think your j'accuse is very un-polite and very bad targeted.  I
> clearly expressed my reasoning, I totally don't care about other browsers
> reasons.  I must ask you to respect out netiquette.

I don't think Markus was being accusations, remember that what one hears in their head may not reflect reality.

I think there is room for clarification still too.

I for one would like to see the elusive telemetry data that is implicitly referred to.

Discussing bugs in a bug tracker seems more practical than digging through a mailing list of random threads.
Whiteboard: [Australis:M-] → [Australis:M-][Australis:P?]
Whiteboard: [Australis:M-][Australis:P?] → [Australis:M-]

Updated

5 years ago
Duplicate of this bug: 942001
Created attachment 8344341 [details] [diff] [review]
patch
Attachment #8344341 - Flags: review?(mak77)
Created attachment 8346483 [details] [diff] [review]
patch v2
Attachment #8344341 - Attachment is obsolete: true
Attachment #8344341 - Flags: review?(mak77)
Attachment #8346483 - Flags: review?(mak77)

Comment 16

4 years ago
Will the History sidebar toggle icon be added back after all? What's the status of the Bookmark sidebar toggle icon?

The Classic Theme Restorer addon includes these icons, but I need to install an addon with 100 features for only 2 icons. So while there is a workaround, it's not very efficient in my case.
(In reply to Markus Popp from comment #16)
> Will the History sidebar toggle icon be added back after all? What's the
> status of the Bookmark sidebar toggle icon?
> 
> The Classic Theme Restorer addon includes these icons, but I need to install
> an addon with 100 features for only 2 icons. So while there is a workaround,
> it's not very efficient in my case.

I think "The Classic Theme Restorer" addon is too fat. It should be split up into many single add-ons, though I don't know any plan to add back them.
(In reply to Tetsuharu OHZEKI [UTC+9] from comment #17)
> though I don't know any plan to add back them.

"though I don't know any plan to add back toggle icons by default Firefox."

Comment 19

4 years ago
(In reply to Tetsuharu OHZEKI [UTC+9] from comment #17)
> I think "The Classic Theme Restorer" addon is too fat. It should be split up
> into many single add-ons, though I don't know any plan to add back them.

To keep using the "Classic Theme Restorer" addon is probably the best solution there is, even if it seems like a lot of overkill to use a feature rich addon for only 2 icons.

But it's nothing new to me. I also use the "Toolbar Buttons" addon which provides a set of more than 100 icons, while I also use only 2 icons of these.

So just to have 4 icons available with fairly basic functionality, I need to use 2 pretty feature rich addons. I even made an attempt to get into developing my own addon with this small set of icons, but I failed to find the exact information I needed (found things which are similar, but not what I needed exactly). So if somebody has hints where to find something like a tutorial how to add a simple lets say "View Source" (that should be easy and is one of my 4 icons) icon to the set, that would be very appreciated.

Sorry for going slightly off-topic here.
Comment on attachment 8346483 [details] [diff] [review]
patch v2

Jared, can you review this patch?
Attachment #8346483 - Flags: review?(mak77) → review?(jaws)
Comment on attachment 8346483 [details] [diff] [review]
patch v2

Review of attachment 8346483 [details] [diff] [review]:
-----------------------------------------------------------------

Please update the patch to have [Australis] in the commit message.

::: browser/components/customizableui/content/panelUI.inc.xul
@@ +35,5 @@
>      </panelview>
>  
>      <panelview id="PanelUI-history" flex="1">
>        <label value="&appMenuHistory.label;"/>
> +      <toolbarbutton id="appMenuViewHstorySideBar" tabindex="0"

s/appMenuViewHstorySideBar/appMenuViewHistorySidebar/ (note the missing 'i' in History and lowercase 'b' in Sidebar)

@@ +41,5 @@
> +                     type="checkbox"
> +                     oncommand="toggleSidebar('viewHistorySidebar'); PanelUI.hide();">
> +        <observes element="viewHistorySidebar" attribute="checked"/>
> +      </toolbarbutton>
> +      <menuseparator id="PanelUI-viewHistorySidebar-separator"/>

I don't think this menuseparator is needed here.
Attachment #8346483 - Flags: review?(jaws) → review+
Created attachment 8349148 [details] [diff] [review]
patch v3

Update the patch
* Include [Australis] to the commit comment.
* Done s/appMenuViewHstorySideBar/appMenuViewHistorySidebar/.
* Remove menuseparator.


Thank you your review, Jared!
Attachment #8346483 - Attachment is obsolete: true
Attachment #8349148 - Flags: review?(jaws)
I can't get the attached patch to apply. Did you modify this patch by hand? The previous patch applied with conflicts, but this one fails much earlier and doesn't leave reject files.

The patch is pretty small so I can just fix it locally, but it would be good to figure out how this patch got broken.
Assignee: nobody → saneyuki.s.snyk
Status: NEW → ASSIGNED
(In reply to Jared Wein [:jaws] (Away 20 Dec to 2 Jan) from comment #23)
> I can't get the attached patch to apply. Did you modify this patch by hand?
> The previous patch applied with conflicts, but this one fails much earlier
> and doesn't leave reject files.
> 
> The patch is pretty small so I can just fix it locally, but it would be good
> to figure out how this patch got broken.

I'm sorry, I updated the patch by my hand.
Comment on attachment 8349148 [details] [diff] [review]
patch v3

Review of attachment 8349148 [details] [diff] [review]:
-----------------------------------------------------------------

Landed on fx-team,
https://hg.mozilla.org/integration/fx-team/rev/8d77e66558eb
Attachment #8349148 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/65ea9623a54f
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29

Updated

4 years ago
QA Contact: cornel.ionce
I was able to confirm the fix for this issue on Windows 7 64-bit [1] Mac OS X 10.9.1 [2] and Ubuntu 13.10 64-bit [3], using:
- the latest Nightly (Build ID: 20140306030201),
- the latest Aurora (Build ID: 20140306004001),
under the assumption that the newly added "History Sidebar toggle item" is the "View History Sidebar" sub-menu of the "Show your history" button. Please confirm.

[1] Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:30.0) Gecko/20100101 Firefox/30.0
[2] Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0
[3] Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(saneyuki.s.snyk)
(In reply to Andrei Vaida, QA [:AndreiVaida] from comment #28)
> under the assumption that the newly added "History Sidebar toggle item" is
> the "View History Sidebar" sub-menu of the "Show your history" button.

Yes. Confirmed.
Flags: needinfo?(saneyuki.s.snyk)
You need to log in before you can comment on or make changes to this bug.