maxRetransmits is not exposed on the Data Channel object

RESOLVED DUPLICATE of bug 1464917

Status

()

defect
P4
normal
Rank:
35
RESOLVED DUPLICATE of bug 1464917
6 years ago
6 months ago

People

(Reporter: jsmith, Unassigned)

Tracking

({dev-doc-needed})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [spec])

Reporter

Description

6 years ago
The maxRetransmits property is provided on data channel creation. However, it is not exposed on the data channel object, even though the W3C spec says it should be exposed.
Reporter

Updated

6 years ago
Whiteboard: [WebRTC][blocking-webrtc-]
backlog: --- → webRTC+
Rank: 35
Priority: -- → P3
QA Contact: jsmith
Whiteboard: [WebRTC][blocking-webrtc-] → [spec]

Comment 1

3 years ago
I think this is fixed. Jesup -- can you confirm?
Flags: needinfo?(rjesup)
No, not fixed yet.
Flags: needinfo?(rjesup)
The property is documented now, but we will need Fx for developers and compat table updates when this is fixed.

https://developer.mozilla.org/en-US/docs/Web/API/RTCDataChannel/maxRetransmits
Mass change P3->P4 to align with new Mozilla triage process.
Priority: P3 → P4

Comment 5

6 months ago
maxRetransmits is correctly exposed on the Data Channel object in current Firefox versions. Could anyone comment on when this was added in order for me to update the compatibility tables on MDN?
(In reply to Jeremy Lainé from comment #5)
> maxRetransmits is correctly exposed on the Data Channel object in current
> Firefox versions. Could anyone comment on when this was added in order for
> me to update the compatibility tables on MDN?

I think bug 1464917 might have added this (FF 62), but needinfo to Dan to be sure.
Flags: needinfo?(dminor)

Comment 7

6 months ago
That bug was about the RTCDataChannelInit item when creating a data channel. This issue is about the attribute on the RTCDataChannel interface. :)

Comment 8

6 months ago
Supplement: Actually you're correct. This has been added by https://hg.mozilla.org/mozreview/gecko/rev/7d3f3515c8ec3db1e0d41ca084a397c30e09322e#index_header. Just tested it to be sure.
Yes, it looks like I cleaned up the webidl a bit when I was getting Felix's patch landed.
Status: NEW → RESOLVED
Closed: 6 months ago
Flags: needinfo?(dminor)
Resolution: --- → DUPLICATE
Duplicate of bug: 1464917
You need to log in before you can comment on or make changes to this bug.