[Email] Email Loading progress bar is not inline with the loading of emails

RESOLVED INVALID

Status

Firefox OS
Gaia::E-Mail
P1
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: asuth)

Tracking

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: TaipeiWW)

(Reporter)

Description

5 years ago
1. Title : Email Loading progress bar is not inline with the loading of emails.
2. Precondition : 
3. Tester's Action : Load Email and configure an account -> On successful creation load emails -> Progress bar is not consistent with the loading.
4. Detailed Symptom (ENG.) : Progress bar is not consistent with the loading.

On Load more emails, some times progress bar is completed before even emails are loading.
5. Expected : Progress bar should be loaded inline with the email loading.
6.Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Revision: 517d3d9f0d7538095799c9c067e398fb8ba96ba2
8. Gaia Master: Reproduced

Updated

5 years ago
Priority: -- → P1
Target Milestone: --- → 1.1 QE3 (24jun)
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+

Comment 1

5 years ago
Leo, can you attach some screenshots for this issue? thanks.
(Reporter)

Comment 2

5 years ago
Hi Domnic,

This was confirmed by asuth on IRC, please see the below comments

09:47   asuth	psingapati: I have a patch from the madrid work week that removes the progress bar and replaces it with just spinning the refresh button
09:47	asuth	I'd like to just land that and avoid the progress indicator issue
09:47	asuth	since the problem is that we are showing the progress of individual syncs in there
09:47	asuth	but we may trigger multiple syncs in the process of fetching messages in a folder

So asuth will replace the loading with refresh , which solves the loading progress bar issue.

Thanks.
(Assignee)

Comment 3

5 years ago
Sorry, I thought I had properly linked this bug to bug 882994 which is what I was talking about on IRC.  Adding it as a see-also now.  I am/was waiting on feedback from :robmac before duping or invalidating this bug, but maybe we should just land that.
See Also: → bug 882994

Updated

5 years ago
Assignee: nobody → bugmail
Invalidating this bug for having bug 882994
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Updated

5 years ago
Whiteboard: TaipeiWW
You need to log in before you can comment on or make changes to this bug.