Upload either hangs at validation, or incorrectly says install.rdf does not exist.

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Add-on Validation
P5
trivial
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: Luke, Unassigned)

Tracking

Details

Attachments

(1 attachment)

6.46 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Created attachment 760743 [details]
devtooltweaks.xpi

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512193848

Steps to reproduce:

I tried to upload an addon for the past few days, and it either fails to give any result, or says,

    Could not parse install.rdf.
    Could not parse `install.rdf`.
    Could not parse `install.rdf`.
    Add-on missing install.rdf.


Actual results:

Working .xpi fails to validate (see attached .xpi file).


Expected results:

It should validate and upload.
(Reporter)

Comment 1

5 years ago
Just found the error in the xml. Odd that Firefox would install a malformatted extension. Maybe it could give a link to http://www.w3.org/RDF/Validator/ when parsing fails, that could eliminate a lot of confusion.
We could have a more useful error message.
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5

Comment 3

5 years ago
https://github.com/mozilla/amo-validator/commit/acfc460cb970f3bab89d69d3ad0cbec49070a3c6
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.