Closed Bug 881606 Opened 8 years ago Closed 8 years ago

[b2g-bluetooth] BluetoothA2dpManager doesn't receive any sink property changed

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gyeh, Assigned: gyeh)

Details

(Whiteboard: [fixed-in-birch])

Attachments

(1 file)

After Bug 872907 is landed, still no sink property changed is received by BluetoothA2dpManager.
In Bug 878745, SinkPropertyChangedHandler is removed accidentally. That's the root cause.
One more thing to say, currently, we need to manually enable Sink and Control interface of Bluez for using A2DP and AVRCP respectively. Here are some details:

adb remount
adb push B2G/system/bluetooth/data/audio.conf /etc/bluetooth/audio.conf
Eric, please help to review this patch. Thanks.
Assignee: nobody → gyeh
Attachment #760759 - Flags: review?(echou)
Attachment #760759 - Flags: review?(echou) → review+
https://hg.mozilla.org/mozilla-central/rev/89aaa839391c
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fix-in-birch] → [fixed-in-birch]
You need to log in before you can comment on or make changes to this bug.