Menu items missing when browser opened using profile created in Ja 6.1b

VERIFIED DUPLICATE of bug 86807

Status

Core Graveyard
Profile: Migration
--
major
VERIFIED DUPLICATE of bug 86807
17 years ago
2 years ago

People

(Reporter: Jon Rubin, Assigned: racham)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Tested on 06-27-06-0.9.2 using WinMe-Ja.

Steps:
1) Create a profile on Ja 6.1b build (06-07-13-0.9.1 Ja).
2) Open US browser using the profile created in Ja browser.  The text for
"File", "Edit", "View", and "Help" menu items is missing.  Also, some items are
missing in the submenus of these items (except "View"--everything appears under
"View").

Bugscape 5802 was originally opened as a Ja bug for this problem, but will be
closed since this is a core issue.  Please refer to 5802 for additional
background info.

Comment 1

17 years ago
Jon,

Does this sound similar to bug 86807?  Seems as though using profiles created in 
either earlier versions or other language versions causes problems. 
(Reporter)

Comment 2

17 years ago
Grace,

Yes, I was thinking the problem sounds similar.  The difference here is that the
profile was created in a localized build, whereas in bug 86807 we are dealing
with profiles that are created in an earlier US build (6.0 or 6.01), but may
have been using a non-English language pack.  The problems do seem related though.
(Reporter)

Comment 3

17 years ago
I installed 06-21-11-0.9.1 Ja, created a profile, and then launched
06-28-06-0.9.2 using the Ja profile. Here's what was missing from the menu:
(note that all menu headings appeared okay)

File: Send Page, Send Link
Edit: Prefill Form, Save Form Data, View Saved Data
View: nothing missing
Search: nothing missing
Go: nothing missing
Bookmarks: no Personal Toolbar Folder (in this case, there is no blank space
where it should appear)
Tasks: Mail, Instant Messenger
Help: nothing missing

Note that in the case where items are missing, it is still possible to click
where the text should be; in other words, the menu items are still functional. I
will attach a couple screenshots of what the menu looks like.

Note that after creating a profile in 6.1b-en and opening in 6.1b-ja, when I
opened the same profile again in 6.1b-en, different items were missing (even
though it was an English profile). When I tried reproducing this with a second
profile, the missing items in the Ja build were the same as listed above, and
nothing was missing when I opened in the US build again. Here's what was missing
in the first profile (on US build):

File, Edit, View, and Help headings were missing. Under each heading, the
following was missing:

File: New
New: Navigator Window, Blank Page to Edit
Edit: Undo, Cut, Copy, Paste, Delete, Select All, Preferences
View: Nothing missing (just the View heading was missing)
Search: Everything under Search the Web missing (there wasn't even blank space)
Go: Nothing missing
Bookmarks: Nothing missing (Even Personal Toolbar Folder appears)
Tasks: Nothing missing
Help: About Plug-ins, About Netscape 6 missing
(Reporter)

Comment 4

17 years ago
Created attachment 40568 [details]
Missing File menu items
(Reporter)

Comment 5

17 years ago
Created attachment 40569 [details]
Personal Toolbar Folder missing

Comment 6

17 years ago
changing qa contact to jonrubin. how is this different from 86807?
QA Contact: gbush → jonrubin
(Reporter)

Comment 7

17 years ago
I really don't think this is different from 86807.  This bug was created from
Bugscape 5802, which was closed as invalid because the problem reported there
was not a localization issue.  My confusion on what's supported stems from
Allan's statement on 06/02 in Bug 5802: 

"A profile created on 5-31 carries no warranty of compatibility with previous
pre-beta releases. We should probably be compatible with US profiles, although
this may not be possible either. Take a look at this after we receive the
complete translations."

This makes it sound like we support only the scenario where a user creates a
profile in one version, such as 6.01, and then upgrades using the same profile.
But is that any different from creating a profile in an earlier build and then
opening it in a later build?  I think if the profile appears in Profile Manager,
we have to guarantee compatibility with that build.

If it is agreed that this is the same as bug 86807, we can probably close this
as a dupe, although bug 5802 is where this problem was originally reported, and
that predates bug 86807.

Comment 8

17 years ago
we need a solution for backwards compatibility, so the comment is not quite
right. Regardless of what bug was logged before, you should close as dup the one
that has less comments on it and keep the one with the more history as the valid
one. We really need Tao to look at these bugs.
(Reporter)

Comment 9

17 years ago
I will talk to Tao about this on Monday and then close this one if it is in fact
a dupe.

Comment 10

17 years ago
Jonathan - Was this a dupe?
(Reporter)

Comment 11

17 years ago
Yes, I will go ahead and mark it as a dupe of bug 86807.  This bug was
originally part of a Bugscape bug that was later split into 3 separate bugzilla
bugs.  In any case, this problem has been fixed.

*** This bug has been marked as a duplicate of 86807 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

17 years ago
Verified per my last comment.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.