Closed Bug 881656 Opened 7 years ago Closed 7 years ago

[SMS] The notification for the received SMS is shown as "Message is not downloaded yet"

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P3)

ARM
Gonk (Firefox OS)

Tracking

(blocking-b2g:leo+)

RESOLVED WORKSFORME
1.1 QE3 (26jun)
blocking-b2g leo+

People

(Reporter: leo.bugzilla.gaia, Assigned: gerard-majax)

Details

(Whiteboard: [TD-42338])

Attachments

(1 file)

1. Title: The notification for the received SMS is shown as "Message is not downloaded yet"
2. Precondition: SMS app should be working
3. Tester's Action: (1) Receive New SMS
                    (2) Check the notification text of newly received SMS
4. Detailed Symptom (ENG.) :The notification text for the newly received SMS is shown as the "Message is not downloaded yet"
5. Expected: The notification text should be proper with small preview of the body received for SMS
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train: Reproduced on v1-train and master
8. Gaia Revision:  bd07ce233160a0e6325bf736769772a9d2273458
9. Personal email id: sasikala.paruchuri8@gmail.com
blocking-b2g: --- → leo+
Whiteboard: [TD-42338]
Target Milestone: --- → 1.1 QE3 (24jun)
This seems only occurs at MMS instead of SMS.
Assignee: nobody → mshiao
Hi Leo, 

I could not reproduce this.  Can you provide video?

Thanks,
Mark
Priority: -- → P3
Attached video Video Attachment
Please find the attached video which shows the notification as "The message not downloaded yet" which is same for all the notifications
Leo,

Thanks for the video.  Obviously something weird is happening.  I still can not reproduce it. Can you provide more information about the sender(phone sending the message) of the sms? For example was a subject defined in the sms which would automatically convert it to a mms.  Can you also send a logcat file?  Probably won't help much in this case but might me worth viewing.

Thanks,
Mark
Leo,

I was able to flash a recent gaia onto a working leo image and did not receive the above error.
I'm thinking it's not related to gaia.  Can you guys verify?

gaia: c74d0ee0692de0171af7b3a3f28b640a3f4fbec1

Thanks,
Mark
Hi Mark, 

(In reply to Mark Shiao from comment #5)
> I was able to flash a recent gaia onto a working leo image and did not
> receive the above error.
> I'm thinking it's not related to gaia.  Can you guys verify?
 
Leo has a patch for this bug and applied to the partner version. 
I think.. that's why you cannot reproduce it.

To Leo, Please attach the patch if you have it.
Thank you
This is a commercial RIL issue i think.
We were getting message.type only for MMS, for SMS it was 'undefined'.
unassinging myself since this bug does not seem to be a gaia issue.
Assignee: mshiao → nobody
I think I hit this one on Leo device with partner build. I'll investigate today.
(In reply to Leo from comment #7)
> This is a commercial RIL issue i think.
> We were getting message.type only for MMS, for SMS it was 'undefined'.

I'm just reproducing this on Leo device, with build 20130607201925, commit a7b14c0ea58a, and SFR SIM card.
Reproduced on Leo, gaia v1-train at cac83b8.

Logs shows that the RIL gets this as SMS correctly.
And this is not dependant on the locale.
Reproduced also on gaia master at e286239.
(In reply to Leo from comment #7)
> This is a commercial RIL issue i think.
> We were getting message.type only for MMS, for SMS it was 'undefined'.

I can confirm this behavior.
I can't reproduce with pvtbuild from today, either inside b2g/ or b2g_ril/.

Can you try to reproduce on a recent build ? Thanks !
Flags: needinfo?(sasikala.paruchuri8)
Assignee: nobody → lissyx+mozillians
Hi gerard-majax ,
As you mentioned this is the RIL problem.
Getting only MMS type.
(In reply to Alexandre LISSY :gerard-majax from comment #14)
> (In reply to Leo from comment #7)
> > This is a commercial RIL issue i think.
> > We were getting message.type only for MMS, for SMS it was 'undefined'.
> 
> I can confirm this behavior.

Are you getting SMS type in latest binary with commeril RIL?
Flags: needinfo?(sasikala.paruchuri8)
(In reply to Leo from comment #16)
> Hi gerard-majax ,
> As you mentioned this is the RIL problem.
> Getting only MMS type.
> (In reply to Alexandre LISSY :gerard-majax from comment #14)
> > (In reply to Leo from comment #7)
> > > This is a commercial RIL issue i think.
> > > We were getting message.type only for MMS, for SMS it was 'undefined'.
> > 
> > I can confirm this behavior.
> 
> Are you getting SMS type in latest binary with commeril RIL?

But you did not answered, are you experiencing this with up to date code ? I can't reproduce myself with up to date build, but with old build I can reproduce.
It is not reproduced in latest build in leo
Thanks, I'll mark this one as WORKFORME then. Feel free to reopen if you hit it again.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.