[Browser] May be a better way to handle the bottom toolbar so content can have more focus

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: epang, Unassigned)

Tracking

({uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: visual design, visual-tracking, uiwanted [UCID:Browser2, FT:Browser, KOI:P2])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
The bottom tool bar on the browser takes up a large amount of space which could be used to view content.

Might be worth looking into a toolbar that disappears on tap that operates similarly to viewing an image in the gallery.
One approach could be to have the toolbar scroll in and out opposite to a user's scroll direction. 

So, if you drag up to scroll a page, the title bar scrolls up and the bottom toolbar scrolls down. Conversely, when you drag down, both the title bar and bottom toolbar are revealed again.

On Android, Google's Search UI does this to a nice effect. Interestingly, iOS7 seems to be doing this now too with Safari.
Duplicate of this bug: 886890

Updated

5 years ago
Whiteboard: visual design, visual-tracking → visual design, visual-tracking, uiwanted
Created attachment 772063 [details]
UX proposal for showing/hiding chrome

Attached is a UX proposal for how to handle the showing and hiding of the browser chrome. Please let me know if you have any questions or comments.
Duplicate of this bug: 889575

Comment 5

5 years ago
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/53546175
(Reporter)

Comment 6

5 years ago
Thanks Francis, this looks great!

Pavel, using the UX proposal Francis created can you please implement this to the browser? Please let know if you have any questions!
Assignee: administration → pivanov
I think I will be busy with [BB] refactoring If anybody can help with this will be great.
Assignee: pivanov → nobody
(Reporter)

Comment 8

5 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #7)
> I think I will be busy with [BB] refactoring If anybody can help with this
> will be great.

No worries, Ian let me know there's a team that will be working on this :)
I have been told that a vision where the wrapper used for bookmarks on the homescreen and the browser navigation should be unified.

The attached specs takes into account only the browser app. Is there any chance that you find a way to address both?
Flags: needinfo?(fdjabri)
Vivien can you please share any sketches / wires you're referring to in this bug, for reference and comparison?
I don't have those myself. Let me needinfo some of our UX folks.
Flags: needinfo?(jcarpenter)
Flags: needinfo?(gbrander)
Keywords: uiwanted
Duplicate of this bug: 908182
Whiteboard: visual design, visual-tracking, uiwanted → visual design, visual-tracking, uiwanted [UCID: Browser1, FT:Browser, KOI:P2]
Whiteboard: visual design, visual-tracking, uiwanted [UCID: Browser1, FT:Browser, KOI:P2] → visual design, visual-tracking, uiwanted [UCID: Browser2, FT:Browser, KOI:P2]

Updated

5 years ago
Flags: needinfo?(fdjabri)
Created attachment 826524 [details]
show:hide chrome v3.pdf
Updated latest version of the UX spec. Changes include:

UX proposal banner removed. Clarifications based of feedback added.
Created attachment 832492 [details]
show:hide chrome v4.pdf

Added the use case of panning a page that's smaller than the full screen height (but larger than the scrollable area with chrome visible)
Whiteboard: visual design, visual-tracking, uiwanted [UCID: Browser2, FT:Browser, KOI:P2] → visual design, visual-tracking, uiwanted [UCID:Browser2, FT:Browser, KOI:P2]
needsinfo should have been cleared w/ Francis' updated spec. Clearing.
Flags: needinfo?(gbrander)
Candice, this didn't make 1.2 (per the whiteboard flags). Can you reset to something in future?
Flags: needinfo?(cserran)
Will be fixed with new system browser which is releasing in 1.4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(cserran)
Resolution: --- → WONTFIX
Flags: needinfo?(jcarpenter)
You need to log in before you can comment on or make changes to this bug.