assertions in nsStyleCoord::GetPercentValue

RESOLVED WORKSFORME

Status

()

defect
P3
normal
RESOLVED WORKSFORME
18 years ago
5 years ago

People

(Reporter: jruderman, Assigned: pierre)

Tracking

Trunk
mozilla0.9.8
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Steps to reproduce:
1. In a debug build, go to http://dell.com/.

Result: assertion in nsStyleCoord::GetPercentValue.

###!!! ASSERTION: not a percent value: 'mUnit == eStyleUnit_Percent', file ..\..
\..\..\dist\include\nsStyleCoord.h, line 159
###!!! Break: at file ..\..\..\..\dist\include\nsStyleCoord.h, line 159

Reproducibility: 75%
Marking dependencies for 2 other bugs that report the "not a percent value" 
assertion.
Blocks: 80921, 90787
per WRMB discussion, making dependent of 90787 topembed.
Keywords: topembed
these are working fine in the 8/17 nightly build (non-debug)
Keywords: topembed
Removed dependency on 90787 and updated url & summary.
No longer blocks: 90787
Summary: dell.com asserts in nsStyleCoord::GetPercentValue → assertions in nsStyleCoord::GetPercentValue
I'm going to attach the offending page in case it changes.  Note that when it is 
stored locally, you need to load it and then reload in order to see the assert.
Keywords: qawanted
It works now: no assertions...  Since the problem seems to come and go, I'm 
pushing this to 0.98 for one more round of test before closing WorksForMe.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.8
Really works for me now...
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.