If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

DeviceStorage: Remove fallback to available storage

RESOLVED DUPLICATE of bug 885753

Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 885753
4 years ago
4 years ago

People

(Reporter: dhylands, Assigned: dhylands)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Assignee)

Description

4 years ago
According to bug 874313 comment 14 we need to remove the fallback to available storage.

For a leo device, there are several ways that you can specify a location to store a file:
1 - /sdcard/dir/file - always stores on internal storage
2 - /extsdcard/dir/file - always stores on external storage (physical sdcard)
3 - dir/file - location is determined via settings

This bug is concerned about files specified as in item 3, when the settings app has the default location set to extsdcard and no sdcard is present.

Current behaviour:
- file location will fallback to internal sdcard

Desired behviour:
- file location will not fallback to internal sdcard, but will rather stay on the external sdcard and the file saves will fail.

The following gaia code uses the available status to determine if its ok to save a new file:
- Taking a screen snapshot
- Doing a bluetooth file transfer
- Taking a still picture with the camera
- Taking a video clip
- Saving email attachments

The current behaviour of the available status, is that if any storage area is available, then the composite area is considered available.

So if you will, there is "available for reading" and "available for writing". Currently these are in sync.

This bug is requesting that available for reading be capable of returning a different result than available for writing.

This further implies that we'll need to add a new API in order to distinguish this, and all of the places in gaia which currently assume that the they're the same will need to be fixed.
This blocks a blocker 874313.
blocking-b2g: --- → leo?
blocking-b2g: leo? → leo+
(Assignee)

Comment 2

4 years ago
Status update: this bug will be fixed by bug 885753
Depends on: 885753
(Assignee)

Comment 3

4 years ago
Marking as a duplicate of bug 885753 since this is fixed by that bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 885753
You need to log in before you can comment on or make changes to this bug.