support relative urls in the location bar

RESOLVED WONTFIX

Status

SeaMonkey
Location Bar
P5
enhancement
RESOLVED WONTFIX
17 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla should accept relative URLs in the location bar.  If a URL typed into
the location bar starts with / or #, or starts with . and looks like a relative
URL, it should be resolved relative the URL of the current page.

 Example       Expected results               Current results
  ..         go to parent dir               tries to resolve host ".."
  ./         go to index or dir listing     tries to resolve host "."
  .emacs     search for ".emacs"            tries to resolve host ".emacs"
  #a         go to named anchor "a"         nothing happens when I hit enter
  /          go to root of website          nothing happens when I hit enter
Proposed algorithm:
1. Ignore spaces at beginning and end of the URL.  (We already do this.)
2. First look for custom keywords such as "/.".
3. If the URL begins with # or / and contains spaces, search for it.
4. If the URL begins with # or / and doesn't contain spaces, treat it as relative.
5. If the URL is . or .., or begins with ./ or ../, treat it as relative.
6. If the URL begins with . but doesn't match rule 5, search for it.
7. If none of the rules above were matched, do whatever we do currently (search
or treat URL as absolute depending on other factors).

Comment 1

17 years ago
please provide examples and steps to reproduce. [and expected behavior]

Comment 2

17 years ago
an interesting thought - I think we'd need to put it on a pref though, so that
people who don't understand the concept of relative links don't get confused.
Keywords: helpwanted
Summary: [rfe] support relative urls in the location bar → support relative urls in the location bar
Target Milestone: --- → Future
(Reporter)

Comment 3

17 years ago
I think it would be pretty hard to trigger this accidentally (when trying to
search), so a pref shouldn't be necessary.

This feature would be particularly useful for keyboard users who don't want to
pick up the mouse just to chop off the end of a URL.  (Bug 79409 would also make
it easier to chop off part of a URL with the keyboard, but not as easy as this
feature would.)

Comment 4

17 years ago
reassign url bar bugs to new owner..
Assignee: alecf → blakeross
Target Milestone: Future → ---

Comment 5

17 years ago
Joe was dying to have these bugs. Who am I to say no?
Assignee: blakeross → hewitt

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P5
Target Milestone: --- → Future

Comment 6

17 years ago
here's a handy bookmarklet I picked up somewhere and put on my personal toolbar

javascript:void(location.href=location.href.substring(0,location.href.substring(0,location.href.length-1).lastIndexOf('/')+1))

it pretty much does the .. for you

-matt

Comment 7

16 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=88178#c6

you can pretty much do all these using Bookmarks, Bookmarklets and the Mozilla
keywords, i already have .. set to bring me up a directory and i use it all the
time.  http://matrix.netsoc.tcd.ie/~horkana/dev/javascript/

you could create a bookmarks file containing all the bookmarklets you need and
just import them into your local copy of mozilla or even wrap them in an XPI. 
maybe it would be worth having them built in but aside from the suggestion about
#a taking you to the named anchor 'a' on the current page, which could almost as
easily be done by typing #a after the current URL i would be surprised if there
were many people interested in these enhancments.  
Sorry to be such a killjoy ...

i would have thought that if your current location was 
www.mozilla.org/
that ./ would reload the current location
in the GTK file dialog clicking on the . refreshes the current view 

http://bookmarklets.com/
Mozilla keywords
http://www.mozilla.org/docs/end-user/keywords.html

Updated

16 years ago
Blocks: 175405
(Reporter)

Updated

16 years ago
No longer blocks: 175405

Comment 8

14 years ago
acutally, I sort of like this idea...
Assignee: hewitt → location-bar
Status: ASSIGNED → NEW
QA Contact: claudius
Target Milestone: Future → ---
Product: Core → SeaMonkey

Comment 9

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 10

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 11

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 12

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 13

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 14

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 15

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
(Reporter)

Comment 16

9 years ago
This is an enhancement request.  Enhancement requests do not expire.
Status: UNCONFIRMED → NEW

Comment 17

9 years ago
The SeaMonkey team will not fix this.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.