[MP] Defect - FF is no longer the default browser program after an update from metro mode when service is not used?

RESOLVED WORKSFORME

Status

Firefox for Metro
Install/Update
P2
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: jbonacci, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
So, I attempted to update FF while in metro mode.
Although I can start this process in metro mode, I had to manually finish it in desktop mode See Bug 881824

I noticed that after the upgrade process, FF is no longer the default browser program.
In addition, the FF icon was missing from the metro mode display (no FF icon/button to push).
Also by swiping up from the bottom and selecting All Apps, FF Nightly is missing from the list!

I had to go back to desktop mode and reselect FF Nightly as the default browser program.
Two ways - from the Advanced > General Prefs in FF Nightly
or
from the Default Programs Control Panel in Windows desktop mode

Updated

5 years ago
OS: Mac OS X → Windows 8 Metro
Summary: FF is no longer the default browser program after an update from metro mode → defect - FF is no longer the default browser program after an update from metro mode
Please re-open if you disagree with anything below:

(In reply to James Bonacci [:jbonacci] from comment #0)
> So, I attempted to update FF while in metro mode.
> Although I can start this process in metro mode, I had to manually finish it
> in desktop mode See Bug 881824

You can restart it in Metro mode, you just have to manually start back the browser twice after clicking to restart.  Bug 874323 will first the first restart.

> 
> I noticed that after the upgrade process, FF is no longer the default
> browser program.
> In addition, the FF icon was missing from the metro mode display (no FF
> icon/button to push).
> Also by swiping up from the bottom and selecting All Apps, FF Nightly is
> missing from the list!

I upgraded through metro and don't see this behavior.

> 
> I had to go back to desktop mode and reselect FF Nightly as the default
> browser program.
> Two ways - from the Advanced > General Prefs in FF Nightly
> or
> from the Default Programs Control Panel in Windows desktop mode

I think you're seeing one of the issues in bug 855311.  I tried reproducing this both with updating from Metro and a Metro + Desktop combo upgrade, but couldn't.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 855311
(Reporter)

Comment 2

5 years ago
Yep, sounds like 874323 and 855311...
Status: RESOLVED → VERIFIED
James could you find exact steps for this? I think we may want to move this into bug 855311 as a dependency there. 

A simple install and then upgrade does not reproduce this. I'd like to find more exact steps.
Flags: needinfo?(jbonacci)
(Reporter)

Comment 4

5 years ago
I can, but not immediately. I will not be near my SurfacePro until Monday (Jun 17).
At that point I will bring it up and attempt to duplicate the exact steps I took (since I fuzzed the description about moving from metro to desktop to complete the upgrade process).
Flags: needinfo?(jbonacci)
OK thanks, I'll re-open for exact steps.  I don't see an exact bug following this issue inside bug 855311.  I'll set the needinfo flag until then so I don't forget about it.
Blocks: 855311
Status: VERIFIED → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(nobody)
Resolution: DUPLICATE → ---
Summary: defect - FF is no longer the default browser program after an update from metro mode → FF is no longer the default browser program after an update from metro mode (Multi install problem?)
(Reporter)

Comment 6

5 years ago
Latest STRs (to the best of my memory):
1. Open FF Nightly in metro mode (default browser is set)
2. Open Settings
3. Click About
4. Click Check for Updates
5. Download happens automatically
(About panel is still open for viewing download)
6. Click the Restart to Update button
7. This appears to close FF Nightly and puts me back in metro mode display
8. Click on FF Nightly icon
This opens the User Account Control window
9. Click Yes to continue
10. Again, this appears to close FF Nightly and puts me back in metro mode display
11. Click on FF Nightly icon again
12. Go back into Settings > About
Note that the update did not appear to happen (version date stamp/release number is the same as before the update was attempted).
13. Click on Check for Updates - I get another update
14. Click on Restart to Update
15. Click on FF Nightly icon
This again opens the User Account Control window
16. Click Yes to continue
Now I am popped over to desktop mode with the following "error"
"Problem with Shortcut"
The item 'firefox.exe' that this shortcut refers to has been changed or moved, so this shortcut will no longer work properly. Do you want to delete this shortcut?"
17. Click Yes to continue
18. Return to metro mode
Note that FF Nightly icon is now gone.
19. Return to desktop mode
20. Click on the Nightly shortcut. Note that it opens nothing (as expected)
21. Click on the Nightly icon in the toolbar
22. Verify that this is the updated version of FF Nightly
So, there it is.
FF Nightly icon is missing from metro mode, shortcut no longer works, FF nightly has been updated, but does not appear to be the default browser anymore in metro mode (since there is no obvious way to launch it).

To verify:
1. Open Control Panel > All Control Panel Items > Default Programs
Note that Nightly is set to be the default: "This program has all its defaults"
2. Close Control Panel
3. Go back to metro mode
4. Bring up "All apps"
Verify that there is no FF Nightly icon

At this point (last time) I think I picked IE as the default browser (or Opera maybe), then reset Nightly as the default browser. 
That gave me an icon for it on All apps and in metro mode
Flags: needinfo?(nobody)
I'm confused at why you're getting the UAC prompt.  Some of this sounds like overlap with bug 882142. But not the part about the shortcut.

Can you confirm if this happens on a clean machine? One that has not had firefox installed before? 

Also can you investigate why you are getting a UAC prompt?  What changes did you do to get that?
Keywords: qawanted
Blocks: 859003
No longer blocks: 855311
Priority: -- → P2
Summary: FF is no longer the default browser program after an update from metro mode (Multi install problem?) → FF is no longer the default browser program after an update from metro mode when service is not used?

Updated

5 years ago
Summary: FF is no longer the default browser program after an update from metro mode when service is not used? → Defect - FF is no longer the default browser program after an update from metro mode when service is not used?
Whiteboard: feature=defect c=tbd u=tbd p=0
(Reporter)

Comment 8

5 years ago
I am going to turn this bug over to Juan for further investigation. I have run out of time on this project for the immediate future and my focus was meant to be on FF sync only...

Juan - can you pick this up from here?
The full QA team probably has a better chance of getting a clean SurfacePro than I do...
Alternately if you want to borrow mine and wipe it clean to repeat the testing, let me know...

Updated

5 years ago
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=Install_and_setup u=tbd p=0

Updated

5 years ago
Blocks: 831592

Updated

5 years ago
Whiteboard: feature=defect c=Install_and_setup u=tbd p=0 → feature=defect c=Install_and_setup u=browser_user p=0
Whiteboard: feature=defect c=Install_and_setup u=browser_user p=0 → feature=defect c=Install_and_setup u=browser_user p=0 [preview-triage]

Updated

5 years ago
Whiteboard: feature=defect c=Install_and_setup u=browser_user p=0 [preview-triage] → [preview-triage] feature=defect c=Install_and_setup u=browser_user p=0

Updated

5 years ago
Blocks: 838081
No longer blocks: 859003
Juan, is this confirmable? See Jame's comment in comment 8.
Flags: needinfo?(jbecerra)
(Reporter)

Comment 10

5 years ago
:Ally Naaktgeboren
Juan is out until the 26th.
Is there anybody else that can reconfirm this?
(I don't even have my Surface Pro at the moment)

Updated

5 years ago
Blocks: 899390
Flags: needinfo?(jbecerra)
Summary: Defect - FF is no longer the default browser program after an update from metro mode when service is not used? → [MP] Defect - FF is no longer the default browser program after an update from metro mode when service is not used?
Whiteboard: [preview-triage] feature=defect c=Install_and_setup u=browser_user p=0 → [preview] feature=defect c=Install_and_setup u=browser_user p=0
I haven't seen this, please re-open if you can reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
No longer blocks: 838081, 831592, 899390
Whiteboard: [preview] feature=defect c=Install_and_setup u=browser_user p=0
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.