Closed Bug 881837 Opened 6 years ago Closed 6 years ago

Change - Snapped urlbar is not long enough and default text gets cut off

Categories

(Firefox for Metro Graveyard :: App Bar, defect, P3)

x86_64
Windows 8
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bbondy, Unassigned)

References

Details

Attachments

(1 obsolete file)

Attached image Snap problems (obsolete) —
See attached image for a visual explanation.

Steps to reproduce:
1. Put Firefox into snapped view.
2. Bring up the URL bar via Windows + Z or right click

Expected results:
a) The URL bar fills out most of the available space
b) The default text in the URL bar says "Enter Search o"

Actual results: 
a') The URL bar fills out just over half of the available space
b') I think just remove the default overlay text when in snapped view. 


Note:
There seems to be a hidden refresh button, I notice when I click on the empty space it reloads the page. Maybe this is causing the empty space. If that is the case and we want a reload button, please show the reload button instead of making the URL bar longer.
Whiteboard: feature=change c=Browser_views u=metro_firefox_user p=0
p=1
:bbondy, did you upload the wrong image? that's not an image in snapped view..
Priority: -- → P3
Duplicate of this bug: 876621
Comment on attachment 761073 [details]
Snap problems

yup wrong image
Attachment #761073 - Attachment is obsolete: true
I don't have a new image but there's extra space we aren't using just to the right of the back button. And when you have a back and forward button you have hardly no space at all to enter a URL.  Maybe it's too much padding or margin on those buttons.
I'm working on this. I have a spec from Stephen and will be working out details with Yuan.
Assignee: nobody → fyan
Status: NEW → ASSIGNED
Depends on: 885242
Blocks: metrov1it10
No longer blocks: metrov1defect&change
QA Contact: jbecerra
Whiteboard: feature=change c=Browser_views u=metro_firefox_user p=0 → feature=change c=Browser_views u=metro_firefox_user p=2
Note to Jonathan:
Fixing bug 885242 will fix this.
Assignee: fryn → jwilde
Assignee: jwilde → nobody
Blocks: metrov1defect&change
No longer blocks: metrov1it10
Status: ASSIGNED → NEW
Whiteboard: feature=change c=Browser_views u=metro_firefox_user p=2 → feature=change c=Browser_views u=metro_firefox_user p=0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
No longer blocks: metrov2defect&change, 831894
Whiteboard: feature=change c=Browser_views u=metro_firefox_user p=0
You need to log in before you can comment on or make changes to this bug.