Closed Bug 881890 Opened 8 years ago Closed 7 years ago
Consider renaming Customizable
UI .get Widget to something clearer
Marco brought this up in bug 873058 - it's not immediately clear that getWidget returns a widget group wrapper. Perhaps this is just a case of needing a better name though...something like, getWidgetGroup? Or is this a case of our widget model being misunderstood?
To me, that's our widget model being misunderstood (but then, I wrote the damn thing). We never give out anything but a wrapper, and what we do give out by default is designed to cover the common use-case (so you can change the widget in all windows, not one-by-one). Not sure if having a getWidgetForWindow() API would help or not. We already have getWidget(...).forWindow(...), and neither would return an actual widget - just a wrapper. Though, what would certainly help is if we had some documentation.
(In reply to Blair McBride [:Unfocused] from comment #1) > > Though, what would certainly help is if we had some documentation. Docs! I don't know if you guys already knew this, but I'm a BIG fan of 'em! I'd even go as far as writing some, occasionally. I'd be more than happy to start on that as soon as possible (now seems like a good time, right before Australis lands and more eyeballs will feast on the new goodies). What would be the right order of things here, bug-wise? One bug per file to document?
(In reply to Mike de Boer [:mikedeboer] from comment #2) > One bug per file to document? WFM. I'd keep it all separate from this bug though, in case we decide we do in fact want to rename getWidget().
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P5]
I actually think this is starting to be too late, and not terrible naming already, so maybe we should just WONTFIX this? Mike?
Yep, fine with it.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.